As the subject says, I can't install git. I tried apt-get update followed by apt-get upgrade, and also tried apt-get install git-core. Have the same issue in all cases, below:

ubuntu-14:~ >> apt-get install git
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  git-man liberror-perl
Suggested packages:
  git-daemon-run git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-arch git-cvs git-mediawiki git-svn
The following NEW packages will be installed:
  git git-man liberror-perl
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,066 kB/3,087 kB of archives.
After this operation, 24.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] 
WARNING: The following packages cannot be authenticated!
  liberror-perl git-man git
Install these packages without verification? [y/N] y
Err http://us.archive.ubuntu.com/ubuntu/ utopic/main git-man all 1:2.1.0-1
  404  Not Found [IP: 2001:67c:1562::17 80]
Err http://us.archive.ubuntu.com/ubuntu/ utopic/main git i386 1:2.1.0-1
  404  Not Found [IP: 2001:67c:1562::17 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/g/git/git-man_2.1.0-1_all.deb  404  Not Found [IP: 2001:67c:1562::17 80]

E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/g/git/git_2.1.0-1_i386.deb  404  Not Found [IP: 2001:67c:1562::17 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

closed as off-topic by steeldriver, Sergiy Kolodyazhnyy, Thomas Ward, Florian Diesch, Pilot6 Feb 15 '16 at 7:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • try apt-get -o Acquire::ForceIPv4=true update then apt-get -o Acquire::ForceIPv4=true install git. Looks like it's not falling back to ipv4 from ipv6 - more info here - unix.stackexchange.com/questions/9940/… – Sir_Scofferoff Feb 15 '16 at 2:26
  • 3
    14.10 is beyond end-of-life: even if you fix other issues, you will not be able to install anything from the original repositories – steeldriver Feb 15 '16 at 2:50
  • 14.10 is long dead and you need to update to a supported release to get continued support here. – Thomas Ward Feb 15 '16 at 5:50
  • Thanks for your responses. I guess I was under the impression that the 14 release had long term support. Do you suggest that I just upgrade it in place? I'd appreciate any pointers for carrying out the upgrade. Thanks again! – M. A. Sridhar Feb 16 '16 at 5:26

You should install git using apt-get way

sudo apt-get update
sudo apt-get install git

only as that's recommended approach.

In case that is not working then try this

sudo apt-get update
sudo apt-get install build-essential libssl-dev libcurl4-gnutls-dev libexpat1-dev gettext unzip

The above method of installing git is to compile the software from source. This takes longer and will not be maintained through your package manager, but it will allow you to download the latest release and will give you some control over the options you include if you wish to customize.

As a work around - all the git repositories also has a alternate way to download the entire contents as a zip file also.

Not the answer you're looking for? Browse other questions tagged or ask your own question.