0

I have ubuntu 14.04 running under virtualbox in windows, and I can't get the screen resolution to go any higher than 640*480. I've seen other posts, and I installed guest additions, but it doesn't work. Does anyone know what I've missed or am doing wrong? Thanks in advance.

EDIT the version of virtualbox i'm using is 5.0.14

0

What you need is the correct VirtualBox guest extensions.

  1. Download the appropriate one for your VirtualBox version from here. My VirtualBox version is 5.0.10 so I used that one but yours might be different so make sure you download the right one. Get a file named VBoxGuestAdditions_[Version].iso where [version] is your VBox version. If your version is something like 4.3 then update to the latest version! This could be the reason why things don't work...
  2. Go to VirtualBox application in windows in the VM you are running.
  3. Go to the settings of the VM you are running. Go to storage tab.
  4. Click on the optical drive on the storage tree (where probably it says "empty") and on the attributes menu next to it press the cdrom icon.
  5. Choose the iso you downloaded.
  6. Fire up a terminal
  7. Type the following in the bash prompt:

    $ sudo mount /dev/cdrom /mnt
    $ cd /mnt
    $ sudo apt-get install -y dkms build-essential linux-headers-generic linux-headers-$(uname -r)
    $ sudo ./VBoxLinuxAdditions.run
    $ sudo reboot
    

If everything goes ok when you boot you will be able to change your resolution to higher settings :)

0

you may also want to try to suggest a resolution in File > Prefs > Display and select hint

It could also be virtualbox being outdated, check in Help > about. Currently we are on 5.0.14; after updating you would also need to update the extension pack - its all here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.