0
$ apt install skype
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gir1.2-langtag-0.5 glassfish-javaee gperf groovy groovy-doc groovy2 gstreamer1.0-doc ivy ivy-doc libabw-dev libaether-java
  libaopalliance-java libaopalliance-java-doc libasync-http-client-java libasync-http-client-java-doc libaxis-java
  libaxis-java-doc libbcpg-java libbcpg-java-doc libbluetooth-dev libboost-date-time-dev libcastor-core-java libcastor-java-doc
  libcastor-xml-java libcdi-api-java libcdr-dev libclassworlds-java libclassworlds-java-doc libclucene-dev libcmis-dev
  libcommons-configuration-java libcommons-configuration-java-doc libcommons-discovery-java libcommons-discovery-java-doc
  libcommons-fileupload-java libcommons-jexl2-java libcommons-jexl2-java-doc libcommons-jxpath-java libcommons-jxpath-java-doc
  libcommons-lang3-java libcommons-lang3-java-doc libcommons-net2-java libcommons-net2-java-doc libcommons-validator-java
  libcommons-vfs-java libcommons-vfs-java-doc libcppunit-1.13-0v5 libcppunit-dev libcppunit-doc libcups2-dev libdoxia-core-java
  libdoxia-java libdoxia-java-doc libdoxia-sitetools-java libdoxia-sitetools-java-doc libdrm-dev:i386 libe-book-dev libeot-dev
  libetonyek-dev libexttextcat-dev libfreehand-dev libgeronimo-ejb-3.0-spec-java libgeronimo-interceptor-3.0-spec-java
  libgeronimo-jms-1.1-spec-java libgeronimo-validation-1.0-spec-java libgeronimo-validation-1.0-spec-java-doc libgl1-mesa-dev:i386
  libglew-dev libglm-dev libgpars-groovy-java libgpars-groovy-java-doc libgraphite2-dev libgssrpc4:i386
  libgstreamer-plugins-base1.0-dev libgstreamer1.0-dev libhessian-java libhessian-java-doc libhttpclient-java libhttpcore-java
  libhunspell-dev libhyphen-dev libisorelax-java libitext1-java libixion-0.10-0v5 libjackson-json-java libjackson-json-java-doc
  libjamon-java libjboss-vfs-java libjcsp-java libjcsp-java-doc libjdependency-java libjdom2-java libjdom2-java-doc
  libjettison-java libjibx-java libjibx1.1-java-doc libjibx1.2-java libjline2-java libjsoup-java libjsoup-java-doc
  libjsr311-api-java libjsr311-api-java-doc libkadm5clnt-mit9:i386 libkadm5srv-mit9:i386 libkdb5-8:i386
  libknopflerfish-osgi-framework-java libknopflerfish-osgi-java-doc liblangtag-dev liblangtag-doc liblangtag-gobject0
  liblpsolve55-dev libmaven-archiver-java libmaven-archiver-java-doc libmaven-clean-plugin-java libmaven-clean-plugin-java-doc
  libmaven-common-artifact-filters-java libmaven-common-artifact-filters-java-doc libmaven-compiler-plugin-2.5-java
  libmaven-compiler-plugin-2.5-java-doc libmaven-dependency-tree-java libmaven-dependency-tree-java-doc libmaven-doxia-tools-java
  libmaven-doxia-tools-java-doc libmaven-filtering-java libmaven-install-plugin-java libmaven-install-plugin-java-doc
  libmaven-invoker-java libmaven-jar-plugin-java libmaven-jar-plugin-java-doc libmaven-javadoc-plugin-java
  libmaven-plugin-tools-java libmaven-reporting-impl-java libmaven-reporting-impl-java-doc libmaven-resources-plugin-java
  libmaven-resources-plugin-java-doc libmaven-shade-plugin-java libmaven-shade-plugin-java-doc libmaven-shared-utils-java
  libmaven-shared-utils-java-doc libmaven-site-plugin-java libmaven-site-plugin-java-doc libmaven2-core-java
  libmaven2-core-java-doc libmdds-dev libmockobjects-java libmspub-dev libmsv-java libmwaw-dev libmysqlcppconn-dev
  libneon27-gnutls-dev libnetty-3.9-java libnspr4-dev libnss3-dev libodfgen-dev liborcus-dev liborcus-spreadsheet-model-0.10-0v5
  libpagemaker-dev libplexus-ant-factory-java libplexus-archiver-java libplexus-bsh-factory-java libplexus-build-api-java
  libplexus-build-api-java-doc libplexus-cipher-java libplexus-cipher-java-doc libplexus-classworlds-java
  libplexus-classworlds-java-doc libplexus-classworlds2-java libplexus-classworlds2-java-doc libplexus-cli-java
  libplexus-cli-java-doc libplexus-compiler-1.0-java libplexus-compiler-1.0-java-doc libplexus-container-default-java
  libplexus-container-default-java-doc libplexus-containers-java libplexus-containers-java-doc libplexus-containers1.5-java
  libplexus-i18n-java libplexus-i18n-java-doc libplexus-interactivity-api-java libplexus-interactivity-api-java-doc
  libplexus-interpolation-java libplexus-interpolation-java-doc libplexus-io-java libplexus-sec-dispatcher-java
  libplexus-sec-dispatcher-java-doc libplexus-utils-java libplexus-utils-java-doc libplexus-utils2-java libplexus-utils2-java-doc
  libplexus-velocity-java libplexus-velocity-java-doc libpoppler-cpp-dev libpoppler-cpp0 libpoppler-dev libpoppler-private-dev
  libpthread-stubs0-dev:i386 libqdox-java libqdox-java-doc libraptor2-dev libraptor2-doc librasqal3-dev librasqal3-doc librdf0-dev
  librelaxng-datatype-java librevenge-dev libservlet3.1-java libsisu-guice-java libsisu-ioc-java libspring-aop-java
  libspring-beans-java libspring-context-java libspring-core-java libspring-expression-java libspring-instrument-java
  libspring-oxm-java libspring-web-java libssl-dev:i386 libstax-java libstax-java-doc libstax2-api-java libsuitesparse-dev
  libsurefire-java libtomcat8-java libvigraimpex-dev libvigraimpex-doc libvigraimpex5v5 libvisio-dev libwagon-java
  libwagon-java-doc libwerken.xpath-java libwoodstox-java libwpd-dev libwpg-dev libwps-dev libwsdl4j-java libx11-dev:i386
  libx11-xcb-dev:i386 libxau-dev:i386 libxbean-java libxcb-dri2-0-dev:i386 libxcb-dri3-dev:i386 libxcb-glx0-dev:i386
  libxcb-present-dev:i386 libxcb-randr0:i386 libxcb-randr0-dev:i386 libxcb-render0:i386 libxcb-render0-dev:i386 libxcb-shape0:i386
  libxcb-shape0-dev:i386 libxcb-sync-dev:i386 libxcb-xfixes0:i386 libxcb-xfixes0-dev:i386 libxcb1-dev:i386 libxdamage-dev:i386
  libxdmcp-dev:i386 libxext-dev:i386 libxfixes-dev:i386 libxmlbeans-java libxshmfence-dev:i386 libxstream-java libxxf86vm-dev:i386
  maven-debian-helper maven-repo-helper maven2 mesa-common-dev:i386 python-h5py python-librdf python-vigra python-vigra-doc
  velocity velocity-doc
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  firebird-dev:i386 firebird2.5-server-common:i386 gstreamer1.0-plugins-base:i386 gstreamer1.0-tools:i386 libaudio2:i386
  libc6-dev:i386 libcap2:i386 libdatrie1:i386 libdbusmenu-qt2:i386 libfbclient2:i386 libfbembed2.5:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386 libib-util:i386 libltdl-dev:i386 libmng2:i386 libmysqlclient-dev:i386
  libqt4-dbus:i386 libqt4-declarative:i386 libqt4-declarative-folderlistmodel:i386 libqt4-declarative-gestures:i386
  libqt4-declarative-particles:i386 libqt4-declarative-shaders:i386 libqt4-designer:i386 libqt4-dev:i386 libqt4-help:i386
  libqt4-network:i386 libqt4-opengl:i386 libqt4-qt3support:i386 libqt4-script:i386 libqt4-scripttools:i386 libqt4-sql:i386
  libqt4-sql-sqlite:i386 libqt4-svg:i386 libqt4-test:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386
  libqtgui4:i386 libqtwebkit-dev:i386 libqtwebkit4:i386 libsqlite3-dev:i386 libthai0:i386 libxss1:i386 libxtst6:i386 libxv1:i386
  linux-libc-dev:i386 nas:i386 odbcinst1debian2:i386 qt4-designer:i386 qt4-dev-tools:i386 qt4-qmlviewer:i386 qt4-qtconfig:i386
  skype-bin:i386 sni-qt:i386 unixodbc-dev:i386 zlib1g-dev:i386
Suggested packages:
  firebird2.5-examples:i386 manpages-dev:i386 libtool-doc:i386 libpq-dev:i386 libsqlite0-dev:i386 qt4-doc:i386 libicu52:i386
  sqlite3-doc:i386 audiooss:i386 qt4-doc-html:i386
Recommended packages:
  libqt4-opengl-dev:i386
The following packages will be REMOVED:
  automoc firebird-dev firebird2.5-server-common kdelibs5-dev libfbembed2.5 libkrb5-dev libmysqlclient-dev libphonon-dev libpq-dev
  libqt4-dev libqt4-opengl-dev libqtwebkit-dev libreoffice-subsequentcheckbase libsqlite0-dev python-sqlite-dbg qt4-designer
  qt4-dev-tools unixodbc-dev
The following NEW packages will be installed:
  firebird-dev:i386 firebird2.5-server-common:i386 gstreamer1.0-plugins-base:i386 gstreamer1.0-tools:i386 libaudio2:i386
  libc6-dev:i386 libcap2:i386 libdatrie1:i386 libdbusmenu-qt2:i386 libfbclient2:i386 libfbembed2.5:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386 libib-util:i386 libltdl-dev:i386 libmng2:i386 libmysqlclient-dev:i386
  libqt4-dbus:i386 libqt4-declarative:i386 libqt4-declarative-folderlistmodel:i386 libqt4-declarative-gestures:i386
  libqt4-declarative-particles:i386 libqt4-declarative-shaders:i386 libqt4-designer:i386 libqt4-dev:i386 libqt4-help:i386
  libqt4-network:i386 libqt4-opengl:i386 libqt4-qt3support:i386 libqt4-script:i386 libqt4-scripttools:i386 libqt4-sql:i386
  libqt4-sql-sqlite:i386 libqt4-svg:i386 libqt4-test:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386
  libqtgui4:i386 libqtwebkit-dev:i386 libqtwebkit4:i386 libsqlite3-dev:i386 libthai0:i386 libxss1:i386 libxtst6:i386 libxv1:i386
  linux-libc-dev:i386 nas:i386 odbcinst1debian2:i386 qt4-designer:i386 qt4-dev-tools:i386 qt4-qmlviewer:i386 qt4-qtconfig:i386
  skype skype-bin:i386 sni-qt:i386 unixodbc-dev:i386 zlib1g-dev:i386
0 upgraded, 59 newly installed, 18 to remove and 0 not upgraded.
Need to get 61.3 MB of archives.
After this operation, 146 MB of additional disk space will be used.

apt-get autoremove gives no output, which means the The following packages were automatically installed and are no longer required is because of Skype.

Why does package skype obsolete so many (probably important!) Java-related packages, and can I have both at once? This is Ubuntu 15.10.

apt-get purge skype gives Package 'skype' is not installed, so not removed.

Installing other packages gives, for instance,

The following extra packages will be installed:
  libfinance-yahooquote-perl
The following NEW packages will be installed:
  libfinance-yahooquote-perl smtm
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.

So it's Skype-specific.


It was recommended in the comments that I remove each of the "the following packages will be REMOVED" one by one to see which give the long list of removals, and I did that like:

A=$(for i in `echo automoc firebird-dev firebird2.5-server-common kdelibs5-dev libfbembed2.5 libkrb5-dev libmysqlclient-dev libphonon-dev libpq-dev libqt4-dev libqt4-opengl-dev libqtwebkit-dev libreoffice-subsequentcheckbase libsqlite0-dev python-sqlite-dbg qt4-designer qt4-dev-tools unixodbc-dev`
    do echo; echo PACKAGE IS $i IS PACKAGE
    echo; echo -e '\04' | apt remove $i; done
) 
printf "$A" > a

I've ended up with the following list:

automoc 
kdelibs5-dev 
libmysqlclient-dev 
libphonon-dev 
libpq-dev 
libqt4-dev 
libreoffice-subsequentcheckbase 
unixodbc-dev

So now the question is more like, why do those packages need to be removed by Skype and why do they cause the long list of obsoletions?

14
  • what 'apt-get purge skype*' does?
    – Ashu
    Feb 14, 2016 at 16:05
  • @Ashu I've edited my question
    – cat
    Feb 14, 2016 at 16:06
  • something is wrong with your command. "apt install skype" should throw an error regarding the lock file and not a list of packages. I would assume it is "sudo apt-get install skype"?
    – Rinzwind
    Feb 14, 2016 at 16:14
  • @Rinzwind apt is aliased to apt-get install, sorry
    – cat
    Feb 14, 2016 at 16:25
  • I'm not convinced that the list of "no longer required" packages is related to the skype installation. What's the answer if you run sudo apt-get upgrade? Feb 14, 2016 at 16:47

1 Answer 1

0

I ended up going ahead and removing the long list of packages, and then reinstalling them all, which works perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .