I have an nvidia GTX 260 896 MB and a Monitor Samsung 225 BW that supports 1680x1050 native. And I need to add and apply resolution to nvidia x server settings viewportout to 1920x1080, but it doesn't let me when i click on apply (on blur) it reverts back to 1680x1050. I tried with addmode and newmode commands but the resolution won't come up. On windows 10 it works fine and can keep the monitor on 1920x1080.

OS: Ubuntu KDE 14.04 LTS

enter image description here

This is what i have in /etc/x11/xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildd@roseapple)  Mon Feb  3 15:07:22 UTC 2014

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 340.96  (buildmeister@swio-display-x86-rhel47-05)  Sun Nov  8 22:50:27 PST 2015

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung S22C300"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 260"

Section "Screen"

# Removed Option "metamodes" "DVI-I-0: 1920x1080 +0+0, DVI-I-3: 1920x1080 +1920+0 {viewportin=1920x1080}; {viewportout=1920x1080}"
# Removed Option "metamodes" "DVI-I-0: 1920x1080 +0+0, DVI-I-3: nvidia-auto-select +1920+0 {viewportin=1920x1080}"
# Removed Option "metamodes" "DVI-I-0: 1920x1080 +0+0, DVI-I-3: 1680x1050 +1680+0"
# Removed Option "metamodes" "DVI-I-0: 1920x1080 +0+0, DVI-I-3: nvidia-auto-select +1920+0 {viewportin=1920x1080}"
# Removed Option "metamodes" "DVI-I-0: 1920x1080 +0+0, DVI-I-3: 1680x1050_60 +1920+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "DVI-I-0: 1920x1080 +0+0, DVI-I-3: 1680x1050_60 +1920+0 {viewportin=1920x1080}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
  • 1
    It didn't work in this particular case, but others trying to achieve the scaling can try xrandr --output DP1 --scale 1.14x1.14 – int_ua Feb 20 '16 at 10:40
  • I got higher resolution multi-monitor setup to work on ubuntu using something like grander --auto --output DVI-I --primary --mode 1920x1080. Can't remember exactly what I did unfortunately. – jamescampbell Feb 23 '16 at 17:42

I would install ARandR and use that GUI instead of NVIDIA or others. It works fine for me to set and keep resolutions using multiple monitors on Ubuntu flavors of linux.

Open a terminal window and install: sudo apt-get update && sudo apt-get install arandr

Then to start using simply find arandr as an app listed in your applications menu.

After installation, find it in the menu : System -> Preferences -> ARandR

Homepage of ARandR : http://christian.amsuess.com/tools/arandr/

  • Installed it but don't see how to add a new resolution. – Adrian Mar 3 '16 at 20:42
  • @user3467855 I have a four monitor setup and it took forever to figure it out. I don't remember and didn't document the steps involved. I had a pain in the ass with Samsung and Dell monitors but finally got them configured and working. Sorry I can provide more that what I already wrote. – jamescampbell Mar 3 '16 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.