0

when I try to install certain 32bit programs like in this case Wine, from the Software Center or from the WineHQ repository, or for example PCSX2 I get errors for missing dependencies. When I try to install the missing dependencies I get errors for more missing dependencies and it goes on an on.

I run Ubuntu 15.10 64bit up to date. My settings:

Ubuntu Software and Updates (I had unsupported backports active before)

PCSX2

sudo apt-get install pcsx2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
pcsx2:i386 : Depends: libgdk-pixbuf2.0-0:i386 (>= 2.22.0) but it is not going to be installed
          Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
          Depends: libgtk2.0-0:i386 (>= 2.24.0) but it is not going to be installed
          Depends: libwxgtk3.0-0v5:i386 (>= 3.0.2+dfsg) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

libglib depends on libgtk, libgtk depends on libglid

sudo apt-get install libglib2.0-0:i386 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
default-jre : Depends: default-jre-headless (= 2:1.7-52) but it is not going to be installed
openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u95-2.6.4-0ubuntu0.15.10.1) but it is not going to be installed
             Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
             Depends: libglib2.0-0 (>= 2.16.0) but it is not going to be installed
             Depends: libgtk2.0-0 (>= 2.8.0) but it is not going to be installed
             Depends: libpango-1.0-0 (>= 1.14.0) but it is not going to be installed
             Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not going to be installed
             Recommends: libgnome-2-0 but it is not installable
             Recommends: libgnomevfs2-0 but it is not going to be installed
             Recommends: libgconf-2-4 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

aptitude:

sudo aptitude install libglib2.0-0:i386 
The following NEW packages will be installed:
libglib2.0-0:i386{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1.175 kB of archives. After unpacking 5.372 kB will be used.
The following packages have unmet dependencies:
libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.46.2-1ubuntu1) but 2.46.1-1 is to be installed.
libglib2.0-0:i386 : Breaks: libglib2.0-0 (!= 2.46.1-1) but 2.46.2-1ubuntu1 is installed.
open: 352; closed: 1536; defer: 284; conflict: 1492         O
The following actions will resolve these dependencies:

   Remove the following packages:      
[List of over a 1000 packages !!!]

Wine

Install from Software Center:

Package dependencies cannot be resolved
This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.
The following packages have unmet dependencies:
wine: 

Terminal:

sudo apt-get install --install-recommends winehq-staging
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
winehq-staging : Depends: wine-staging (= 1.9.3~ubuntu15.10.1)
E: Unable to correct problems, you have held broken packages.

:

sudo apt-get install wine-staging
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
wine-staging : Depends: wine-staging-i386 (= 1.9.3~ubuntu15.10.1)
E: Unable to correct problems, you have held broken packages.

:

sudo apt-get install wine-staging-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
wine-staging-i386:i386 : Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                      Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                      Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                      Recommends: libgnutls26:i386 but it is not installable
                      Recommends: libgtk-3-0:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Synaptic

  • Tried fixing broken packages, there are none.

  • Searched for libglib2.0-0:i386, nothing.

  • Searched for libglib generally:

    Synapctic

  • Marking libglib2.0-dev for installation removes gdm, gnome, ubuntu-desktop and settings, unity, libglib.2.0-0 and much more, downgrades libglib2.0-0, installs libpcre3-dev, libpcre32-2, libpcrecpp0v5, zlib1g-dev.

  • Marking libglib2.0-0-dbg for installation again removes all the stuff, installs nothing new, downgrades libglib2.0-0.

So libglib2.0-0 is already installed, apparently the 64 bit version, right? Or is the libglib2.0-0:i386 also already installed? 64bit software like Dolphin, Retroarch or Steam are working and installed correctly. Could this all be a problem of missing headers somewhere?

I really have no idea. Please help me. Thank you.

1
0

The solution to the answer can be found here: http://forums.pcsx2.net/Thread-Ubuntu-15-10-64bit-Missing-i386-dependencies-libglib2-and-libgtk2

All thanks to the help of gregory from pcsx2. I manually forced libglib2.0-0 to the correct version via Synaptic, which fixed the problem. In the process of reinstalling libglib, ubuntu-desktop, gdm,gnome and ubuntu-gnome-desktop are being removed so after rebooting you have to install those again via command line (crtl+alt+f1), reboot again and everything should be fine then. At least that's how I solved this problem.

0

I hit the same on Ubuntu 16.04. The root cause: Intel Linux Graphics updater tool breaking some packages.

I installed ppa-purge and removed it with:

sudo ppa-purge -s download.01.org ppa:gfx/ubuntu
-1

It is important that you have the same version of a libary in 32 and 64 bit, otherwise you can't install the other arch.

You have to activate 32 bit libs by:

sudo apt-get install ia32-libs

And you may have to to add universe reposetory as well.

12
  • I think I have universe already enabled. See link 1 in OP. sudo apt-get install ia32-libs Reading package lists... Done Building dependency tree Reading state information... Done Package ia32-libs is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: lib32z1 lib32ncurses5 E: Package 'ia32-libs' has no installation candidate – amnesiackid Feb 14 '16 at 14:56
  • You are missing atleast one repostory. It is probaly deactivated in your systemsettings. This shold also trigger a packet base update. – Kupferdrache Feb 14 '16 at 14:59
  • Here is the link to the repositories from the OP i.stack.imgur.com/hmYe1.png – amnesiackid Feb 14 '16 at 15:01
  • Looks correct so far, what about the other software ans sigantures tabs? – Kupferdrache Feb 14 '16 at 15:02
  • Also, for wine you need to add the winehq reposetory. (other software) – Kupferdrache Feb 14 '16 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.