This question already has an answer here:

So i got some problems with ubuntu on my Acer Aspire 7750G i5 Radeon HD 6650M 4GB Ram 64Bit

Installed Ubuntu 11.10 64bit

so my first problem is window dragging; if i drag mozilla or any other windows it gets laggy and the cursor is behind

my seccond problem is how to remove the Hardware is not supported watermark after installing the graphic card drivers

thx for yor help

marked as duplicate by Mitch, Luis Alvarado Apr 29 '13 at 21:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    You should split this question into two questions. – Kris Harper Oct 28 '11 at 20:56

The Catalyst 11.9 is now in the Ubuntu repos, and you can install it.

Look here: Amd HD 6850M, Acer 7750G driver issues


I have the same problem. I think, we should report the watermark as a bug.

However the watermark is right, the driver fails back to VESA, so the driver not supports the card, but in previous versions it worked. Even if the closed-driver not works and not fixable, the Ubuntu shouldn't install it for these computers.

If you just want to remove the watermark, you can use the sript below, but that wont fix your problem, your driver will still fail back to VESA. It would be even better now to remove the closed driver. (Well, in this case the removing of the driver will fail, so you will have to reinstall your system... sorry)

The script:

for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
 sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER

Not the answer you're looking for? Browse other questions tagged or ask your own question.