3

In Chrome (and Firefox) while playing youtube videos HTML5 there is only stereo sound output. I am able to play 5.1 surround sound in VLC, so the hardware & Ubuntu setup is correct.

Windows users have the option of launching Chrome with:

--disable-audio-output-resampler but I was not even able to get that to work on my Windows machine.

Is there a way to use html5 surround 5.1 with Chrome on Ubuntu on Youtube or other sites like Vimeo?

Using Ubuntu 14.04 with Chrome 54.0.2840.59

EDIT:

After executing killall pulseaudio I carefully backed up the contents of the /.config/pulse/ directory and then removed the dir manually, restarted the pulse engine with pulseaudio -k , then restarted Chrome. Still no surround sound in Chrome using Youtube.

2
  • 1
    Did my answer not help? I could use some feedback here.
    – negusp
    Nov 1 '16 at 16:22
  • Did you try with another web sound source? a source that is true 5.1...
    – mattia.b89
    Nov 5 '16 at 17:10
3

Apparently YouTube does not support true 5.1

5.1 support only means that Youtube gathers audio from the extra channels, then converts them into 2.0 output so the sounds are sent to all speakers.

HERE is a Stack Exchnage post I read about this

0

You can still launch Chrome in Ubuntu with launch parameters

--disable-audio-output-resampler

--try-supported-channel-layouts

Open the the Chrome config file:

sudo nano /usr/share/applications/google-chrome.desktop

Find the line containing the path to the Chrome:

Exec=/usr/bin/google-chrome-stable %U

And change it to:

Exec=/usr/bin/google-chrome-stable --disable-audio-output-resampler --try-supported-channel-layouts %U

Note: It is also possible that the file google-chrome.desktop is in ~/.local/share/applications/google-chrome.desktop

3
  • not working, not sure why. I have launched ~/.local/share/applications/google-chrome.desktop with Exec=/usr/bin/google-chrome --high-dpi-support=1 --force-device-scale-factor=1.5 --disable-audio-output-resampler --try-supported-channel-layouts %U (the other entries are for high dpi support) Nov 2 '16 at 18:57
  • used this URL - youtube.com/watch?v=eL9-sIZRDHg Nov 2 '16 at 19:00
  • i also tried removing my high dpi parameters and simply executing with what you suggested and still nothing worked.I also tried other URLs to test with. Do you have surround working on your Chrome browser? Nov 2 '16 at 19:15
0

Use something you know supports 5.1, like HTML5 AAC Audio Playback Tests - Multichannel. If that test doesn't work, and Chrome is using pulse than you know the issue is with Pulse Audio and you must dive deeper.

Next play something in Chrome, like this long ass Infected Mushroom album which is 100% good. Leave it playing, and while it's playing run pacmd list-sink-inputs. It should show you something like this

1 sink input(s) available.
    index: 381
    driver: <protocol-native.c>
    flags: START_CORKED 
    state: RUNNING
    sink: 1 <alsa_output.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00.analog-stereo.2>
    volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
            balance 0.00
    muted: no
    current latency: 56.23 ms
    requested latency: 23.22 ms
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
                 Stereo
    resample method: (null)
    module: 14
    client: 410 <Chromium>
    properties:
        application.icon_name = "chromium-browser"
        media.name = "Playback"
        application.name = "Chromium"
        native-protocol.peer = "UNIX socket client"
        native-protocol.version = "31"
        application.process.id = "2148"
        application.process.user = "ecarroll"
        application.process.host = "x230"
        application.process.binary = "chromium-browser"
        window.x11.display = ":0.0"
        application.language = "en_US.UTF-8"
        application.process.machine_id = "0275a7cffa4379527ee564ba552469a2"
        application.process.session_id = "c2"
        module-stream-restore.id = "sink-input-by-application-name:Chromium"

Going through this, this is the index of the sink,

    sink: 1 <alsa_output.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00.analog-stereo.2>

And, this is the data the sink-input is currently receiving, if this isn't right then the source you're playing isn't right and it's not your problem.

channel map: front-left,front-right
             Stereo

It should read like this if the music is 5.1

channel map: front-left,front-right,front-center,lfe,rear-left,rear-right
             Surround 5.1

Now run this.

pacmd list-sinks | grep -i "channel\|index"

This should show you all of the sinks (channels) that can accept sound. Pay attention to the one with the corresponding index, if it shows you something like this.

channel map: front-left,front-right

Then you /know/ that pulse will be downmixing the channel to stereo. Otherwise, we'll need more information.

4
  • Thanks for the reply, but it seems YouTube does not support 5.1 Nov 8 '16 at 19:53
  • @KalamalkaKid your question isn't specific to YouTube, and if it was it's highly confusing there is no No 5.1 surround sound, because the source doesn't support 5.1 surround sound? What's the purpose of the question? Try playing something that does. Nov 8 '16 at 20:13
  • Thank you for your reply. The question in the 4th sentence does not specifically mention YouTube, however in the first sentence I specifically mention that i am trying to use the YouTube service with 5.1. Nov 8 '16 at 20:42
  • 1
    @KalamalkaKid fixed your question then, now that we know it's what you're asking. Nov 8 '16 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.