So this is my first post on the Ubuntu forums and probably my most important question that I will ever ask. I've read around about disabling mouse acceleration in Ubuntu, I'm sure that most of them work fine but I'm having a little problem. Bear in mind I am very new to Linux and I know little to none about commands.

The problem is when I put xinput list into the terminal, my mouse get's outputted in 3 different places.

alan@alan:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SIGMACHIP USB Keyboard                    id=9    [slave  pointer  (2)]
⎜   ↳ SteelSeries Sensei Raw Gaming Mouse       id=10   [slave  pointer  (2)]
⎜   ↳ SteelSeries Sensei Raw Gaming Mouse       id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ SIGMACHIP USB Keyboard                    id=8    [slave  keyboard (3)]
    ↳ SteelSeries Sensei Raw Gaming Mouse       id=11   [slave  keyboard (3)]

So when I want to disable the acceleration on the mouse, which one am I meant to use? Because using id numbers, which change at every restart, is not going to work out because I would love to make some file to execute the mouse acceleration disabling commands at every startup automatically. Will the commands below be successful at disabling the mouse acceleration?

xinput set-prop 'Name' 'Device Accel Profile' -1

xinput set-prop 'Name' 'Device Accel Constant Deceleration' 1

Seems every year or so my touch-pad acceleration turns itself on again on Ubuntu. This year the workaround was as follows:

Install some new software:

sudo apt-get install xserver-xorg-input-libinput libinput-tools

Display properties:

xinput list-props 12

Reduce sensitivity:

xinput set-prop 12 141 0.800000, 0.000000, 0.000000, 0.000000, 0.800000, 0.000000, 0.000000, 0.000000, 0.800000

Disable finger scrolling:

xinput set-prop 12 286 0, 0, 0

I should add you need to put these commands in ~/.profile to have them on by deFault. Also the "magic number" 12 above comes from the output of the xinput list command:

 xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ HD WebCam                                 id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys                          id=13   [slave  keyboard (3)]

Hope it helps someone else!

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.