0

I've been trying to install mysql-server for 2 hours. The system is on Ubuntu Wily.

There's nothing added in the log files.

root@Erman:~# dpkg --configure mysql-server-5.6
Setting up mysql-server-5.6 (5.6.28-0ubuntu0.15.10.1) ...
2016-02-13 18:15:50 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2016-02-13 18:15:50 0 [Note] /usr/sbin/mysqld (mysqld 5.6.28-0ubuntu0.15.10.1) starting as process 25352 ...
2016-02-13 18:15:50 25352 [Note] Plugin 'FEDERATED' is disabled.
2016-02-13 18:15:50 25352 [Note] InnoDB: Using atomics to ref count buffer pool pages
2016-02-13 18:15:50 25352 [Note] InnoDB: The InnoDB memory heap is disabled
2016-02-13 18:15:50 25352 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2016-02-13 18:15:50 25352 [Note] InnoDB: Memory barrier is not used
2016-02-13 18:15:50 25352 [Note] InnoDB: Compressed tables use zlib 1.2.8
2016-02-13 18:15:50 25352 [Note] InnoDB: Using Linux native AIO
2016-02-13 18:15:50 25352 [Note] InnoDB: Using CPU crc32 instructions
2016-02-13 18:15:50 25352 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2016-02-13 18:15:50 25352 [Note] InnoDB: Completed initialization of buffer pool
2016-02-13 18:15:50 25352 [Note] InnoDB: Highest supported file format is Barracuda.
2016-02-13 18:15:50 25352 [Note] InnoDB: 128 rollback segment(s) are active.
2016-02-13 18:15:50 25352 [Note] InnoDB: Waiting for purge to start
2016-02-13 18:15:50 25352 [Note] InnoDB: 5.6.28 started; log sequence number 1626183
2016-02-13 18:15:50 25352 [Note] Binlog end
2016-02-13 18:15:50 25352 [Note] InnoDB: FTS optimize thread exiting.
2016-02-13 18:15:50 25352 [Note] InnoDB: Starting shutdown...
2016-02-13 18:15:52 25352 [Note] InnoDB: Shutdown completed; log sequence number 1626193
insserv: warning: script 'K01vncserver' missing LSB tags and overrides
insserv: warning: script 'vncserver' missing LSB tags and overrides
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.6 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 mysql-server-5.6
  • Try sudo apt-get install mysql-server-5.6 – Raphael Feb 13 '16 at 17:32
  • @Raphael nope, getting the same error :( – Duncan Feb 13 '16 at 17:34
  • 1
    sudo apt-get install mysql-server^ – Chris Feb 13 '16 at 17:40
  • 1
    Please refrain from swearing when posting on this site. – kos Feb 13 '16 at 17:41
1

I've switched from upstart to systemd, and now I can install it without any problems.

0

The error says it's missing two scripts regarding Virtual Network Computing Server (vncserver) that's supposed to be from the Linux Standard Base (LSB). Try doing some cleaning, spcifically:

sudo sh -c "apt-get update; apt-get dist-upgrade; apt-get -f install"

,and then trying to install again.

I got the idea from: http://help.directadmin.com/item.php?id=379, but I don't feel as free to recommend deleting things on an assumption.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.