14

Why is it that I don't see my NVIDIA graphic adapter under VGA compatible controller but under 3D controller when I use lspci -vnn? What's the difference between the two and under which section should it actually be?

Edit : Output Of lspci -k | grep -EA2 'VGA|3D'

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
    Subsystem: Dell Device 0662
    Kernel driver in use: i915
--
08:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)
    Subsystem: Dell GeForce 820M
2
  • Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command.
    – Pilot6
    Feb 13 '16 at 15:38
  • @Pilot6 Just edited as you asked.
    – 7_R3X
    Feb 13 '16 at 15:45
7

It depends on the adapter firmware how it declares itself to PCI bus.

Some Nvidia laptop adapters declare themselves as a 3D controller.

That does not make any practical difference.

The reason for that is probably because in an Optimus dual graphics systems, the Nvidia chip is not a real adapter. It outputs through the Intel adapter anyway and does only hardware acceleration.

You can install a proprietary driver in System Settings -> Software & Updates -> Additional Drivers (nvidia-352), or in terminal:

sudo apt-get install nvidia-352

Both methods do the same. This will install the stable recommended driver.

If you need "the latest" drivers, you can install them by

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-361 nvidia-prime

at your own risk.

7
  • binarytides.com/install-nvidia-drivers-ubuntu-14-04 describes the process of installing latest nvidia drivers for ubuntu. Would it work if my adapter describes itseld as 3D controller?
    – 7_R3X
    Feb 13 '16 at 15:32
  • Driver installation is the same. But the manual is outdated and will not work. xorg-edgers does not contain Nvidia drivers now. Why not install recommended driver from Ubuntu repositories a normal way.
    – Pilot6
    Feb 13 '16 at 15:35
  • Err.. I have no idea how to go that normal way. I searched google and that was the first result I found. Mind telling me about it?
    – 7_R3X
    Feb 13 '16 at 15:37
  • Go to System Settings -> Software & Updates -> Additional Drivers and select a driver there.
    – Pilot6
    Feb 13 '16 at 15:39
  • For some reason, this doesn't seem to work. For last many months, even after updating and upgrading my system, Additional Drivers continues to show the same version and I doubt if they're the latest version.
    – 7_R3X
    Feb 13 '16 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.