1

I had setup vnc through vncserver script http://manpages.ubuntu.com/manpages/hardy/man1/vnc4server.1.html .This script were launched under the root. After that i decide to use xrdp instead vnc and remove vnc4server package. Worse luck, the login dialog were changed by Xrdp. And now it's depend from default lightdm dialog. But must horrible thing is only the root can login in system now. Other users authorization challenges are fails.

root@mediacenter:~# stat /etc/passwd
File: '/etc/passwd'
Size: 2230          Blocks: 8          IO Block: 4096   regular file
Device: 805h/2053d  Inode: 920089      Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2016-02-13 00:01:55.338874970 +0300
Modify: 2015-09-29 23:43:56.607963741 +0300
Change: 2015-09-29 23:43:56.641963316 +0300
 Birth: -root@mediacenter:~# stat /etc/shadow
File: `/etc/shadow'
Size: 1727          Blocks: 8          IO Block: 4096   regular file
Device: 805h/2053d  Inode: 920737      Links: 1
Access: (0640/-rw-r-----)  Uid: (    0/    root)   Gid: (   42/  shadow)
Access: 2016-02-13 00:39:03.394275815 +0300
Modify: 2015-09-29 23:43:56.461965559 +0300
Change: 2015-09-29 23:43:56.495965141 +0300
Birth: -

As seems above this files weren't modified since september of 2015.

content of /etc/lightdm/lightdm.conf is:

[SeatDefaults]
autologin-guest=false
autologin-user=sergii
autologin-user-timeout=0
autologin-session=lightdm-autologin
greeter-session=lightdm-gtk-greeter
user-session=ubuntustudio

I will be very grateful if someone show me the way how to repair login in my system.

Login dialog is a little different from default ligtmd dialog originally shipped with system

Also, i were tried run Users Setting application from "System" -> "Users and Groups" but it hangs when launching

When I going to terminal mode with Ctrl+Alt+F4 then login as other user is OK. So it seems that XServer fails to start session for users except for root.

  • What exactly do you mean that "only the root can log in"? Do you mean the system logs in as sergii automatically without giving you a chance to change to a different user? – steeldriver Feb 13 '16 at 14:16
  • No, this behavior where later, when all were OK and autologin had worked. Now I have the login screen on system startup. For instance, I choose 'sergii', type password for sergii account, click 'Log In' - display goes to black for few seconds and login dialog is showed again. When I choose root account then login process is successful. Also login dialog is a little different from default ligtmd dialog originally shipped with system. Also, i were tried going to "System" -> "Users and Groups" this application hangs when booting. – Sergii Feb 13 '16 at 16:00
0

The problem is solved. The /home/$user/.Xauthority owner were changed by something (I think, that it might by XVnc service). Owner were "root" instead "$user". I type "chown $user:$user /home/$user/.Xauthority" and all is great now. I can log in my account without any problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.