0

My wifi is not working. The ethernet works well. Wifi also works in windows dual boot. Hence it isnt hardware problem. Please advice.

iwconfig
eth0      no wireless extensions.
lo        no wireless extensions.
wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=20 dBm  
Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
      Power Management:off

dmesg | grep Wireless
[   14.639861] input: HP Wireless hotkeys as /devices/virtual/input/input6

lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.1 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #2 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.4 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #5 (rev e3)
00:1c.5 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #6 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 07)
09:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/820M / GT 620M/625M/630M/720M] (rev a1)
0a:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

lspci -knn | grep Net -A2
0a:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company Device [103c:2231]
    Kernel driver in use: rtl8723be


rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

ifconfig && iwconfig && route -n && ping -c 1 google.com
eth0      Link encap:Ethernet  HWaddr d0:bf:9c:0a:ce:7d  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:15178 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15216 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:11868737 (11.8 MB)  TX bytes:1948892 (1.9 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1699 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1699 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:240328 (240.3 KB)  TX bytes:240328 (240.3 KB)

wlan0     Link encap:Ethernet  HWaddr 74:29:af:94:27:59  
          inet addr:10.10.0.1  Bcast:10.10.0.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:9877 (9.8 KB)

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.10.0.0       0.0.0.0         255.255.255.0   U     0      0        0 wlan0
ping: unknown host google.com
  • Please edit your answer with the output of the following commands (run them in a terminal window): iwconfig dmesg | grep Wireless. – Eduardo Cola Feb 13 '16 at 13:53
  • Previous comment wants output of 'iwconfig' as one command, and 'dmesg | grep wireless' as second command. I would also add to provide the output of 'lspci' to help identify the actual wireless chipset that you are using. – karora Feb 13 '16 at 13:58
  • 2
    Possible duplicate of Realtek 8723BE Wifi problem – Pilot6 Feb 13 '16 at 14:12
  • None of the solutions marked worked for me. Please help!!! – doodle1234 Feb 13 '16 at 14:49
  • Some body please help!! – doodle1234 Feb 13 '16 at 15:13
0

According to iwconfig, your device is set to Master mode:

wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off

In order to connect to an access point, it should be set to Managed, also known as Infrastructure. Please click the Network Manager icon, select 'Edit Connections' and delete all previous connections. Then, under Wifi, select Infrastructure.

Then, check under IPv4 settings and under Method, select 'Automatic(DHCP)'; be certain it is NOT set to shared.

Save and close. Restart Network Manager:

sudo service network-manager restart    

Now see if the NM icon sees your network and will connect.

It may take a reboot.

  • I suspect that OP made a new network instead of connecting to an existing one in NM. – Pilot6 Feb 13 '16 at 15:37
  • There is no connection by the current router in 'Edit Connections'. – doodle1234 Feb 13 '16 at 15:55
  • from this it says my router doesnt support infrastructure mode. – doodle1234 Feb 13 '16 at 16:01
  • Please see my edit above in a few moments. I assume your card supports Managed mode. – chili555 Feb 13 '16 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.