1

I bought a second hand hp elitebook 2170p, windows 7 preinstalled. I installed ubuntu erasing windows 7 (UEFI mode). Before installing on UEFI mode, I tried using "legacy" mode (selected from boot menu), but I couldn't load ubuntu from the usb drive (kept saying boot device not found, this is only in legacy mode). Anyway, i did install ubuntu but I cannot load grub. I can only start it navigating in the EFI file.

I tried using boot-repair, it did some magic but same problem. The only difference is that I was getting "Intel boot manager" on my screen after starting the laptop, followed by "boot device not found" - after using boot-repair, I cannot see "intel boot manager" anymore, go straight to "boot device not found" screen.

This is the url generated by boot-repair:http://paste.ubuntu.com/15034469/

Could you please help?

Thanks

1

After the repair, it should be working. Search your output for efibootmgr results. (There are three such examples, the last of which is the final state and shows an Ubuntu/GRUB entry, hence my statement that it should be working.) If it's not working at this point, I have several suggestions, which you should try in order:

  1. Try updating your firmware to the latest version. This may get you clear of bugs in some EFIs. Note that you'll have to re-run Boot Repair once you've done this.
  2. Try going into the firmware setup utility, locate an option to reset all the settings to their defaults, and use it. With that done, try running Boot Repair again.
  3. (Perhaps not an option for you, given that it's a secondhand computer....) Return the computer for a refund, because it's defective. If you bought it new, I'd say to also write to the manufacturer to say why you've done so. Note that by "defective" I don't mean "sample defect," I mean "defective design."
  4. Copy your boot loader to EFI/BOOT/bootx64.efi on the ESP. This is most easily done by launching the Boot Repair tool, entering the Advanced menu, and picking the option to copy the boot loader to backup filenames. (I don't recall the exact phrasing of the option, but it should be obvious.)

If you get to #4, it will probably work acceptably on a single-boot installation, but that's a hackish workaround for a buggy firmware that's likely to fail sooner or later if you dual-boot with any other OS.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.