7

After upgrading to 11.10 from 11.04 (I think), some of the icons such as the folder icons in Nautalus are replaced with the generic file icon... This makes it hard to navigate.

Is there any easy way to fix this?

6
  • Have you tried changing the theme in appearance System Settings? Commented Oct 28, 2011 at 20:35
  • That didn't help, most icons are either the generic file one, or blank. Commented Oct 28, 2011 at 20:44
  • Can you post a pastebin link of the output of ls /usr/share/icons -R Commented Oct 28, 2011 at 21:55
  • Here's some of the output, it was too long to post everything. Note how some folders are empty. pastie.org/2775673 Commented Oct 28, 2011 at 22:27
  • Thats normal, it just means some icons are not available in all sizes, which theme are you using? Commented Oct 28, 2011 at 22:52

2 Answers 2

9

I had the same problem on two of my computers. After a great deal of time - even a conplete re-install, I discovered that it was a simple configuration setting. Here is what worked for me:

System Settings / Appearance / Select Radiance theme

All my icons magically re-appeared.

1
  • swapping themes and then back worked for me
    – Jim Ford
    Commented Jan 14, 2013 at 12:44
5

Seem like you've got some missing them icons. Try running

sudo apt-get --reinstall install humanity-icon-theme gnome-icon-theme

If your icons are still not fixed you can also try

sudo apt-get --reinstall install gnome-icon-theme-full

You can also try removing/moving ~/.icons

1
  • 2
    I reinstalled the first two, but it didn't change the number of files in /usr/share/icons. Then I installed gnome-icon-theme-full, logged out and back in, and the problem was fixed. I doubt gnome-icon-theme-full is needed, but installing it triggered whatever needed to be done to get the icons to appear. Commented Feb 12, 2012 at 5:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .