2

I am looking for a way to install the CUDA toolkit without the use of a .run installer from nvidia's website. I tried this before (and it installed successfully), however it caused havoc every time the kernel updated. I was advised by multiple sources to revert to an earlier backup and install CUDA again, using the package manager route.

ATTEMPT 1

So far, I have followed all the instructions at http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/#axzz3zypHweWG Chapter 3.6 - Ubuntu Package Manager Installation.

After several pre-installation checks, you are supposed to use the package manager to install a rather large .deb file from the nvidia website (or equivalently use a lightweight network-based .deb installer).

$ sudo dpkg -i cuda-repo-<distro>_<version>_<architecture>.deb

The documentation informs us that:

When using RPM or Deb, the downloaded package is a repository package. Such a package only informs the package manager where to find the actual installation packages, but will not install them.

Therefore, we complete the installation with the following:

$ sudo apt-get update
$ sudo apt-get install cuda

However apt-get very quickly zipped through the "install cuda" part in a second or so, displaying some banalities about the terms of use, then terminated without errors. However there were no signs of the CUDA toolkit having been installed.

For instance, I couldn't continue to setting the environment variables:

$ export PATH=/usr/local/cuda-7.5/bin:$PATH

because /usr/local/cuda-7.5 was never created.

ATTEMPT 2

Having run sudo apt-get purge cuda, I saw that some people had used

$ sudo apt-get install cuda-toolkit

with better results. Asking for the nvcc -version command also suggests downloading this package.

This ran for a little while longer, which was reassuring. However after installation there was still no such directory as /usr/local/cuda-7.5/

Am I missing something obvious, or is this package manager method totally ineffectual?

  • This happens for me as well. – Boyko Perfanov Aug 22 '16 at 12:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.