I installed the latest version of Dropbox from the official site but when it starts the icon on the indicator appears corrupted:

enter image description here

I don't have any way to set preferences or watch progress, however it seems that Dropbox is correctly syncing my documents.
zI already tried a lot of other solutions but none of them worked, my OS is Xubuntu 15.10.


EDIT 02/15/2016

I already tried stopping and restarting the service but it didn't help.
My question is not a duplicate of this for the following reasons:

  • I am using Xubuntu, not Ubuntu
  • In Xubuntu the icon is in the "Indicator Plugin" panel item and I can't edit its properties directly
  • The answer seems quite old (more than one year ago)
  • So this is a purely aesthetical problem? Have you tried changing your icon theme? Feb 12, 2016 at 18:07
  • Hello, unfortunately this is not just an aesthetical problem because I can't click on that icon, it is completely broken and non functional. Changing the theme simply shows the "icon not found" icon from the selected theme.
    – StockBreak
    Feb 12, 2016 at 18:10
  • Try tweaking with Xfce's panel settings/item. Whisker menu > "Preferences" button > Panel > Items. Double click items to see their settings. Feb 12, 2016 at 18:16
  • Hi stock, if you quit dropbox and restart, is it fixed? Please let me know. If so, we can fix it. Feb 13, 2016 at 20:40
  • 2
    @EduardoCola the icon is in the "Indicator Plugin" item and so I can't edit the properties for the single icon, but for the whole panel item only. JacobVlijm I tried restarting the service many times but it didn't work.
    – StockBreak
    Feb 15, 2016 at 8:54

2 Answers 2


As suggested by kk78 in this post, there is now an even better answer that doesn't have the sudo side effects:

dropbox stop && DBUS_SESSION_BUS_ADDRESS="" dropbox start

So I copied* my desktop entry:

cp ~/.config/autostart/dropbox.desktop ~/.config/autostart/start_dropbox.desktop

Changed the entry like this (please notice the env word):

[Desktop Entry]
GenericName=File Synchronizer
Comment=Sync your files across computers and to the web
#Exec=dropbox start -i
Exec=env DBUS_SESSION_BUS_ADDRESS="" dropbox start -i

And disabled Dropbox's autostart:

dropbox autostart n

* you cannot just edit it because Dropbox replaces the file every time you log in.


Thanks to Juan M. Gonzalez, as written in this post, a temporary but working solution is the following:

dropbox stop
sudo dropbox start # please notice the sudo!

EDIT 02/16/2016

Please note that this solution is still working (and I'm still using it) but it has side effects with file permissions. Please look into this thread for a list of proposed solutions:

Dropbox icon is not working Xubuntu 14.04 LTS 64


Not the answer you're looking for? Browse other questions tagged .