Affects: 14.04 / 14.10 / 15.04 / 15.10 / 16.04 / 16.10

I started my dropbox deamon today, with the following result in the panel:


The icon with the warning/failed symbol should be my Dropbox icon. I cannot right-click or left-click it, so no interaction.

I am running Xubuntu 15.10 on 4.2.0-27-generic x64. I also tried to re-install Dropbox, reinstall nautilus-dropbox, recursively delete ./cache/sessions/ as well as set other themes and icon sets.

Apparently nothing helped and similar problems described here and on other boards are similar, not the same and do not work in my case.

  • 1
    Started happening on 14.04 as well.
    – mreq
    Commented Feb 12, 2016 at 13:09
  • 1
    Seems to be a Dropbox version related Happens with Dropbox 3.14 on KDE4 and XFCE. The good news is that Dropbox works, and only the icon is missing. I have two separate user accounts on this PC, one displays the failure icon, and the another still displays the Dropbox icon.
    – user505460
    Commented Feb 14, 2016 at 0:17
  • 2
    Although it is a bug, since it can be fixed askubuntu.com/questions/562259/dropbox-icon-in-the-wrong-place/…, please don't mark it as off-topic. Commented Feb 14, 2016 at 7:45
  • 2
    Yes, please dont mark it as off-topic, I am now on 15.10 and the problem still exists. Thanks @JacobVlijm for your link- while reading this, I found a link to a linux mint forum, suggesting to stop the dropbox service and start it with root privs (i.e. sudo). This solves the icon problem, however, the user / nautilus lacks privileges, e.g. to display the green markers for successful syncing etc.. So this whole thing, seems to be a privilege problem with Dropbox Commented Feb 14, 2016 at 16:28
  • 1
    Yes, the link @JacobVlijm postet, suggests the same thing- however, please see my comment above. This whole thing seems to be a permission problem with dropbox -.- Commented Feb 14, 2016 at 16:30

10 Answers 10


A more recent workaround that works for more Linux operating systems than the DBUS_SESSION one:

dropbox stop && dbus-launch dropbox start

EDIT: To make this permanent see answer by @juankvillegas below.

  • 2
    Yes, I can confirm this. And imho, this suggestion is even better: With the old workaround I git a dbus error, when opening a file inside the dropbox tree with gvim (from nautilus). I will accept this answer, since it has less side-effects. Commented Feb 29, 2016 at 10:42
  • 1
    This was the only workaround of a few I tried that worked for 14.04 Xfce with Crouton. Thanks!
    – jbrock
    Commented May 26, 2016 at 20:37
  • Still works great in Ubuntu 18.04
    – Terrance
    Commented Dec 5, 2018 at 3:39

The answer given by @Juan M. Gonzalez is the best one, but you have to run that command every time you restart your PC.

A permanent fix would be:

  • Run the proposed command once to make the Dropbox icon appear in your notification area: dropbox stop && dbus-launch dropbox start
  • Open Dropbox preferences (click on the Dropbox icon in the notification area).
  • Disable "Start Dropbox on system startup" and apply your changes.
  • Go to XFCE settings > Session and Startup > Application Autostart.
  • Search for an existing Dropbox item and confirm it is disabled.
  • Add a new item with this configuration (do not edit the existing Dropbox item because it is recreated in each reboot):
    • Name: Dropbox
    • Command: dbus-launch dropbox start -i
  • Be sure that the new application is enabled in the list.
  • This worked great! Before I saw this I just tried editing the existing startup item, but it reverted back after restart, also just adding a new item and deleting the old one didn't work. Only after doing your "Disable "Start Dropbox on system startup" " step it worked. So it is essential. Thx!
    – Ur Ya'ar
    Commented Sep 28, 2016 at 17:13
  • Doesn't work for me (the permanent one, that is). Xenial / Xubuntu Commented Oct 3, 2016 at 12:24
  • @WolfgangNoichl, Are you getting an error message in the console when executing dropbox stop && dbus-launch dropbox start? Commented Oct 3, 2016 at 16:09
  • 2
    @WolfgangNoichl I suppose dropbox was started first as part of saved session. To make the Application Autostart work even if you have dropbox as part of saved session, you have to stop dropbox first by dropbox stop.
    – jarno
    Commented Oct 4, 2016 at 11:17
  • @jarno that did the job, thx! Commented Oct 4, 2016 at 12:08

This instruction only work for Xubuntu, UbuntuStudio 16.04 (Not working in 17.04)

In you terminal run

sudo gedit /usr/bin/dropbox

Create a new line after import os and add the following:

os.environ['DBUS_SESSION_BUS_ADDRESS'] = ""

Save and rebot

Here a Gif I made:

Gif tutorial

And, if someday Dropbox update and not working more, repeat this tutorial


Dropbox icon is not working Xubuntu 14.04 LTS 64

This applies to UbuntuStudio 15.10, 16.04 and Xubuntu (both based on XFCE)


This worked for me (xubuntu 15.10):


That is shown here:

Dropbox icon is not working Xubuntu 14.04 LTS 64

  • 1
    Very nice, this finally worked! I added the important part of the line to ~/.dropbox-dist/dropboxd so nautilus starts dropbox the right way. Thanks a lot! Commented Feb 19, 2016 at 10:52

I think it's an issue related to the indicator plug-in. If you don't use it, I suggest you remove it from your panel. The Dropbox icon should then appear normally in the notification area.

  • 1
    I already had the indicators removed (because of the annoying envelope symbol). However, the answer of @Fernando Basso had the final clue! Commented Feb 19, 2016 at 10:51
  • this the only solution works for me xubuntu 17.04 XD
    – Kokizzu
    Commented Sep 11, 2017 at 11:09

I had the same problem on Linux Mint 17. The solution for me was

dropbox stop && DBUS_SESSION_BUS_ADDRESS="" dropbox start

Here's what I did in Xubuntu 16.04

I remove the indicator applet.

The Dropbox icon appeared.

I added the indicator applet. Moved it to where it was before.

Done !

DropBox icon

To get Dropbox integration in Thunar:

sudo add-apt-repository ppa:xubuntu-dev/extras

sudo apt-get update

sudo apt-get install thunar-dropbox-plugin

Thunar integration

  • That's what I did, too! Well, first used dropbox stop && dbus-launch dropbox start which worked but still left the indicator applet.. So I ended up removing the latter anyway, which left my lovely Dropbox icon there working perfectly. Yours is a simpler, useful answer though! -Xubu 16.04
    – P Smith
    Commented Jun 16, 2016 at 19:08

I finally got it working reliably.

  1. Remove the indicator-plugin from the panel. The dropbox icon now appears properly in the Notification Area. The network connection appears there too. But the audio control is now gone.
  2. Add the xfce4-pulseaudio-plugin using synaptic. Then add it to the panel.
  3. Log out, then log back in. Everything should show up properly.
  • How do you compare the pulseaudio plugin with the indicator-plugins Sound Menu? Anyway, Dropbox icon can be shown in Notification Area even if Indicator is in use. See my answer.
    – jarno
    Commented Oct 4, 2016 at 12:48
  • The plugin is only available for 16.04 and later.
    – jarno
    Commented Oct 5, 2016 at 6:17
  • I have two laptops, both with xubuntu 16.04. On one of them, Dropbox works fine; I have never fixed it with custom start scripts. Most odd ... this answer explained the difference between the two configurations and it is the most elegant solution. Commented May 1, 2017 at 13:57
  • Plugin available here: launchpad.net/xfce4-pulseaudio-plugin. See also this askubuntu.com/questions/1034047/… ; I needed libpulse-dev, libxfce4util-dev, libxfce4ui-2-dev, libxfce4panel-2.0-dev. Hopefully that saves someone some time!
    – dez93_2000
    Commented Jul 3, 2018 at 17:55
  • Note: this duplicates the pulseaudio volume icon popup for me, i.e. when changing volume. Right click on the panel icon, properties, unclick 'show notifications'. Now it only comes up once.
    – dez93_2000
    Commented Jul 6, 2018 at 14:35

Make sure that Notification Area is an item in Panel Preferences; the icon will be shown in Notification Area.

Run the following in terminal:

dropbox stop && dbus-launch dropbox start

Then right-click the Dropbox icon, and click "Preferences...". Disable "Start Dropbox on system startup".

If you use saved sessions, make sure dropbox is not an item in them: Start the session, run dropbox stop and thereafter save the session.

Create an init script for dropbox by running this once in terminal as regular:

echo 'description "Dropbox"
start on desktop-start
expect daemon
exec env DBUS_SESSION_BUS_ADDRESS= dropbox start -i' >"${XDG_CONFIG_HOME-$HOME/.config}/upstart/dropbox.conf"

Note: In 12.04 you have to store the file in "$HOME/.init", instead. In 14.04 the directory is deprecated. See Upstart documentation.

Note: env DBUS_SESSION_BUS_ADDRESS= could be replaced by dbus-launch in the above.

Now you can start dropbox by

start dropbox

Then icon should be visible.

The service will be started automatically after next login. The init script starts dropbox in such a way that it is invisible to the session manager and will not be saved in sessions thereafter.

I tested it in 14.04 (that uses Upstart) and 16.04 (that uses systemd). Updating dropbox should not break this fix like it does with some other solutions.

I got some of the ideas from this answer. There is some background information in that answer.

  • For some reason this does not work correctly anymore in 14.04; the system tries to display the Indicator icon instead, but fails to do it properly.
    – jarno
    Commented Jan 17, 2018 at 13:38
  • This fixed problem for me in Ubuntu 19.04. After updating, none of my old apps could talk to panel anymore. Re-running the notification area app fixed the problem.
    – pauljohn32
    Commented May 3, 2019 at 21:27

In Xubuntu 16.04, I found this to work:

  1. sudo mousepad /usr/bin/dropbox
  2. After import os add os.environ['DBUS_SESSION_BUS_ADDRESS'] = ""
  3. dropbox stop
  4. dropbox start
  • Like the exact same thing the user @Washington Indacochea Delgado posted on March 11? Commented May 22, 2016 at 13:26
  • Except it stopped working. I had to run "dropbox stop" and "dropbox start" manually after boot-up.
    – Syster
    Commented May 25, 2016 at 4:06
  • @Syster maybe due to Dropbox update which overwrote the file. See my answer for an alternative solution.
    – jarno
    Commented Oct 4, 2016 at 12:50

Not the answer you're looking for? Browse other questions tagged .