I've just upgraded Libreoffice from 5.0.4 to 5.1 and I've noticed that menus don't integrate anymore with Unity bar. Any hints on how to proceed? I've already tried to uninstall and reinstall with no success.

  • 3
    Could you mention how you installed LibreOffice 5.1? – DK Bose Feb 12 '16 at 12:27

I assume that you upgraded manually, using the installation file from LibreOffice.
But you should wait until LibreOffice 5.1 is available in the LibreOffice Fresh PPA.

This usually does not take a very long time after a new LibreOffice version release.
When you do it this way, integration with the Ubuntu Unity menu bar will work fine.

To add the LibreOffice Fresh PPA to the repositories, open a terminal and execute :

sudo add-apt-repository ppa:libreoffice/ppa  
sudo apt-get update

When the new LibreOffice edition arrives - you can upgrade to version 5.1 as usual :

sudo apt-get upgrade

LibreOffice PPA description : This PPA will have what the Document Foundation calls "LibreOffice fresh", the latest release of the newest series (but no alpha/beta releases).

LibreOffice 5.1 release notes : This is the first release of the 5.1.x branch of LibreOffice which contains new features and program enhancements. As such, the version is stable and is suitable for all users. This version may contain a few annoying bugs which will be fixed in the next bugfix versions to come ... so, you may want to consider waiting until LibreOffice 5.1.1 will be released.

Update information 2016-02-23 : LibreOffice 5.1.0 is now available in the LibreOffice Fresh PPA.
LibreOffice Unity integration works in Ubuntu 14.04.4, but it still does not work in Ubuntu 15.10 !

Update information 2016-03-02 : LibreOffice 5.1.1 is now available in the LibreOffice Fresh PPA.
The issue is fixed and LibreOffice 5.1.1 integration with the Unity menu bar works flawlessly now.

  • I maybe was to anxious and used to: sudo add-apt-repository ppa:libreoffice/libreoffice-5-1 I guess I'll downgrade and wait for the LO Fresh PPA. Thanks. – Víctor Feb 12 '16 at 13:00
  • Oops... Sorry I'm quite new to using this forum and don't know how to proceed. I thought I should promote the solution that worked for me but you are right that officially supported solution is what should be promoted. Sorry again. 'O_O – Víctor Feb 25 '16 at 8:20

Maxim Monastirsky in bug#97830 gave a solution, cite: "Remove the libreoffice-gtk3 package.". For me it did the job in ubuntu 15.10 x64 and libreoffice

  • It worked for me! And also solved some scrolling issues. Thanks. – Víctor Feb 24 '16 at 10:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.