8

I want to upgrade Sublime Tex 3, downloaded the deb, but I get the following error:

Breaks existing package 'sublime-text-installer' conflict: sublime-text ()

How do I upgrade Sublime correctly?

  • try to unistall the current sublime text and install the new version again, there is a big chance to solve the problem – moein rahimi Feb 12 '16 at 6:36
3

I assume you have sublime package so this worked for me

sudo apt-get install --only-upgrade sublime-text
  • 2
    This assumes that sublime-text is in one of OP's systems package repositories, which is not the default. – David Foerster Oct 25 '16 at 12:19
7

Happened to me too. A quick search on the internet revealed that you can solve this by removing the deb package information using the following command in the terminal.

sudo dpkg -r sublime-text-installer
0
sudo apt-get purge sublime-text-installer

run this before installing new package..!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.