0

On all 3 of my Ubuntu 14.04.3 workstations when restarted the UFW firewall is deactivated and has to be started manually sudo ufw enable. My UFW.conf is set to enable startup as follows:

# Set to yes to start on boot. If setting this remotely, be sure to add a rule
# to allow your remote connection before starting ufw. Eg: 'ufw allow 22/tcp' ENABLED=yes

0

I know this was a while ago, but here is a solution.
(Duplicate of 14.04 missing “/etc/init.d/ufw”? my firewall never auto starts)

For the effort that went into figuring out the solution, the answer is surprisingly simple.

In /etc/init/ufw.conf:

1) Comment out lines 9 - 11 2) Insert after line 11: start on startup

Fixes the whole problem, including logging to /var/log/ufw.log.

Note
If you have iptables-persistent installed, you must disable it. Move iptables-persistent out of /etc/init.d and rename all the symlinks in rc0.d-rcS.d by making the 1st letter (S or K) lower case. (Or move them out.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.