2

I have deployed a juju-gui charm and was going to use it for deploying charm from local repository. When I drag the zip file from Desktop it throws me an error. This is the snapshot of juju-gui throwing me an error when I drag the zip file

My juju version is 1.25.0 but it says that it must be greater than 1.18

What could be the problem?

2
+200

That error is shown when there is an error uploading the local charm to Juju, Juju is returning a status code greater than 400. It's possible that there is an upload limit that we were yet unaware of and need to investigate.

In the mean time you can deploy your local charm using the instructions found here: https://jujucharms.com/docs/1.25/charms-deploying#deploying-from-a-local-repository

For those interested here is a link to the tracking issue: https://github.com/juju/juju-gui/issues/1349

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.