2

How to open gimp ,

i have installed gimp on ubuntu 14.04 from the software center but when i click the icon nothing happens , then i typed gimp on the terminal and i get the following message

"Segmentation fault (core dumped)"

also there is a software crash notification gimp crash notice

ps -aux | grep gimp terminal result is

11724 0.0 0.0 15944 2204 pts/0 S+ 17:48 0:00 grep --color=auto gimp

Things that i have tried :

uninstalling and reinstalling it using ubuntu software center

uninstalling and reinstalling it using synaptic manager

performing the following commands

  sudo apt-get autoremove gimp gimp-plugin-registry

  sudo add-apt-repository ppa:otto-kesselgulasch/gimp

  sudo apt-get update

  sudo apt-get install gimp

nothing is working

what can i do now , gimp was my favorite image editor back in windows and now i am not able to use it in ubuntu 14.04

  • Try unistalling it then installing it again using the method in this question -> askubuntu.com/questions/134035/… – Parto Feb 11 '16 at 12:30
  • thanks for the reply , tried the method in the question but gimp still does not open – Siddharth Sekhar Feb 11 '16 at 13:00
  • What have you tried exactly? Did you get any errors? Kindly edit your question and include this information. – Parto Feb 11 '16 at 13:02
  • Try to remove (backup first) the directories (in your home) of gimp defaults. In my system they are ~/.gimp-2.6/ and ~/.gimp-2.8. You can find yours with the command find ~ -name "*gimp*" --- be careful though. Another way to find the problem is to run strace -f gimp and trying to see where it chokes exactly (warning --- very big output expected). – Rmano Feb 11 '16 at 14:37
  • no its not opening : ( – Siddharth Sekhar Feb 11 '16 at 15:50
1

i found a solution that worked for me . Just created a folder name .gimp-2.8 in my home directory

mkdir .gimp-2.8 

do not use sudo and it solved my problem :)

  • Ah --- ok. Got it. Never use graphical application as root, or at list call that with sudo -H (this is due to a in my opinion worng sudo default in Ubuntu, see askubuntu.com/questions/673022/… -- closed wrongly, I think) – Rmano Feb 12 '16 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.