0

For some reason, my new Ubuntu 14.04 Desktop machine always starts disconnected from the network. I'm quite sure I did something to the Network Manager when putting it on a static IP address.

After a reboot, I go into the Network control panel and turn it on, and everything is okay. Same situation if I restart the Network-manager service.

Looking for suggestions on where to check for the setting.

  • I checked /etc/NetworkManager/NetworkManager.conf and managed=true
  • I checked /var/lib/NetworkManager/NetworkManager.state and NetworkingEnabled=true

I'm running this as a VM so there's no WiFi or anything; networking comes back fine as soon as I connect via the control panel.

Thoughts?

  • 1
    Try to run a nm-connection-editor. Edit the connection you want to have and in General tab switch on "Automatically connect to this network when it is available". – nobody Feb 11 '16 at 6:40
  • I think you are on the right track. The eth0 (ifupdown) connection is grayed out for editing. Checking via the Network connection manager panel, I see that the check box is unchecked (but grayed out). I will look for another way to set it. – Matt Coblentz Feb 11 '16 at 15:00
0

Note to self: make sure that the router is also set to reserve the static IP address. Once I updated the router (which I had forgotten to do), everything worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.