0

In the history of me having this machine, I've successfully been able to get a stable installation of Linux on my computer one time. All other times, either I did something stupid when I was playing around, or it was a graphics driver problem.

I've installed the beta versions of both the Ubuntu-specific and generic Linux AMD Catalyst drivers, as well as just used the recommended AMD-compatible drivers given to me by the OS in Settings, and many times I'll restart and the graphics will crash and I'll be sent to a TTY. From here, I attempt to revert my changes and undo the damage, but sometimes different people's advice ends up making it worse.

So...I'm asking the community. Based on the hardware specs I have below, is there a specific process that any of you would recommend for me to get the correct drivers installed and operational?

Honestly at this point, I'm really wanting as specific of instructions as I can get because I'm frustrated at this whole process.

Hardware specs:


FROM LSHW


H/W path Device Class Description

======================================================

/0 bus Motherboard

/0/0 memory 7867MiB System memory

/0/1 processor Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz

/0/100 bridge Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller

/0/100/1 bridge Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port

/0/100/1.1 bridge Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port

/0/100/1.1/0 display Tahiti LE [Radeon HD 7870 XT]

/0/100/1.1/0.1 multimedia Tahiti XT HDMI Audio [Radeon HD 7970 Series]

/0/100/2 display Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller

/0/100/14 bus 7 Series/C210 Series Chipset Family USB xHCI Host Controller

/0/100/14/0 usb2 bus xHCI Host Controller

/0/100/14/1 usb1 bus xHCI Host Controller

/0/100/14/1/1 input Razer BlackWidow Ultimate 2013

/0/100/14/1/2 input Razer DeathAdder Chroma

/0/100/16 communication 7 Series/C210 Series Chipset Family MEI Controller #1

/0/100/1a bus 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2

/0/100/1a/1 usb5 bus EHCI Host Controller

/0/100/1a/1/1 bus Integrated Rate Matching Hub

/0/100/1b multimedia 7 Series/C210 Series Chipset Family High Definition Audio Controller

/0/100/1c bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 1

/0/100/1c.3 bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 4

/0/100/1c.3/0 storage ASM1062 Serial ATA Controller

/0/100/1c.4 bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 5

/0/100/1c.4/0 enp5s0 network NetLink BCM57781 Gigabit Ethernet PCIe

/0/100/1c.5 bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 6

/0/100/1c.5/0 bridge ASM1083/1085 PCIe to PCI Bridge

/0/100/1c.7 bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 8

/0/100/1c.7/0 bus ASM1042 SuperSpeed USB Host Controller

/0/100/1c.7/0/0 usb4 bus xHCI Host Controller

/0/100/1c.7/0/1 usb3 bus xHCI Host Controller

/0/100/1d bus 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1

/0/100/1d/1 usb6 bus EHCI Host Controller

/0/100/1d/1/1 bus Integrated Rate Matching Hub

/0/100/1f bridge Z77 Express Chipset LPC Controller

/0/100/1f.2 storage 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode]

/0/100/1f.3 bus 7 Series/C210 Series Chipset Family SMBus Controller

/0/2 scsi0 storage

/0/2/0.0.0 /dev/sda disk 120GB Samsung SSD 840

/0/2/0.0.0/1 /dev/sda1 volume 99MiB Windows FAT volume

/0/2/0.0.0/2 /dev/sda2 volume 127MiB reserved partition

/0/2/0.0.0/3 /dev/sda3 volume 111GiB Windows NTFS volume

/0/2/0.0.0/4 /dev/sda4 volume 449MiB Windows NTFS volume /0/3 scsi1 storage

/0/3/0.0.0 /dev/sdb disk 1TB WDC WD1002FAEX-0

/0/3/0.0.0/1 /dev/sdb1 volume 931GiB Windows NTFS volume /0/4 scsi2 storage

/0/4/0.0.0 /dev/sdc disk 1TB WDC WD10JPVX-22J

/0/4/0.0.0/1 /dev/sdc1 volume 511MiB Windows FAT volume

/0/4/0.0.0/2 /dev/sdc2 volume 927GiB EXT4 volume

/0/4/0.0.0/3 /dev/sdc3 volume 3681MiB Linux swap volume

NOTE: I'm not sure why it's listing two models of Radeon, but I have the 7870.

1

The first one is your GPU, the second is the HDMI audio output. I have the same card. I recently switched to the opensource radeonsi drivers and they work quite ok.

A complete install instruction you find in the wiki:https://help.ubuntu.com/community/RadeonDriver

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.