0

I have a brand new Dell Inspiron 15 (5559) laptop with an Intel Skylake i7-6500U CPU and an AMD Radeon R5 M335 graphics card. I'm running elementary 0.3.2 which is based on Ubuntu 14.04 LTS, and I figure the problem might not be exclusively related to elementary which is why I also post my question here.

Installation of freya 0.3.2 seems to have worked quickly and without problems. However, I cannot shutdown the system without having to use the power button. The shutdown process stops at a line that looks like this:

[2969.600864] init: wait-for-state (plymouth-shutdownlightdm) main process (14172) killed by TERM signal

I've tried a fix that involved editing the grub menu and seemed on point, but it didn't work. Now I suspect it might have to do with the graphics card (not sure though) because when I shut down the machine, the following happens:

  • for a split second, there is a graphical glitch - it looks like a rectangular part of the desktop wallpaper is moved and shifted

  • the following screen appears: log out output pt. 1

  • after a split second, the next screen appears: log out output pt. 2

There the shutdown process stops. When I hit the power button, the machine powers down (I don't have to hold the button). I can't post the output right now because I'm new to askubuntu and not yet allowed to post more than two links.

So far I have used the Xorg open source drivers for AMD cards that came with freya, although the system mistakenly identifies the graphics card as being an AMD Sun XT (Radeon HD 8600M series). When I switched to the proprietary fglrx driver that shipped with the system, I could merely boot into a black screen with a colored line at the top.

Irrespectively of the AMD drivers, when I have a look at the info tab in the system settings, it says "Graphics: Intel Corporation Device 1916 (rev 07)". When I run lspci -nn | grep VGA, the output is:

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:1916] (rev 07)

The problem also occurs at logout, but in this case the process stops at the screen in the first picture.

Any ideas? I'm a bit confused...

EDIT 1:

Now I have experienced the shutdown/logout to stop at the first graphical glitch without going to the output screens, too. In that case, I have to force quit and power down by holding the power button.

EDIT 2:

Now there's an error message at startup that seems to be related to the problem. I can't post the output right now because I'm new to askubuntu and not yet allowed to post more than two links.

The entry under "Unreportable Reason" (strangely the only one in German) translates to: "This is not an official elementary package. Please remove all third-party packages and repeat the process"

What could that mean?

EDIT 3:

I thought fglrx drivers had been included in the system installation because in the additional drivers tab I had an option for that. However, searching for fglrx in synaptic revealed that apparently there are no such driver packages installed.

So the problem might as well be related to the Intel graphics chipset that apparently is run right now?

Any ideas for help are greatly appreciated!! I already have posted this in the elementary stack exchange, but no replies so far... :(

0

I found the solution. The problem is a driver issue with the Intel Skylake graphics chipset. You can solve it by upgrading to kernel 4.3 and upwards. For instructions to update to kernel 4.4 see here: http://ubuntuhandbook.org/index.php/2016/01/how-to-install-linux-kernel-4-4-in-ubuntu/

The only problem is that now there are some random graphical glitches appearing from time to time. It is kind of annoying, but doesn't affect functionality in any way. I guess the drivers for Skylake graphics aren't fully developed yet.

0

Ok. I had the same problem with my dell 5559. Fixed this problem by opening the terminal and type the following command.

  1. sudo gedit /etc/default/grub

    Find the line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    and change it to:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
    
  2. Type sudo update-grub in terminal

  • I had tried that one before, it's part of the solution offered here: linux.koolsolutions.com/2009/08/04/… - but unfortunately none of these options worked for me, so I had to update the kernel – deesnook Mar 10 '16 at 22:05
0

OK, so the problem can be solved much easier than installing a new kernel - namely by activating the proprietary drivers for AMD Radeon graphics card (called fglrx). You can choose between fglrx and the open source xorg drivers in the additional drivers tab of the update settings. After fglrx has been installed, the problem doesn't occur anymore.

So it looks like either the Xorg drivers - which are activated by default - do not work with an AMD Radeon M335, or the problem is the Intel Skylake graphics chipset because the AMD card isn't detected/activated at all without the fglrx drivers (this might be the case because when I ran "lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2" the AMD Radeon card wasn't detected at all, but I can't tell for sure).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.