1

I am a new Ubuntu user. After initial install of my OS one of the first things I did was install Google Chrome (google-chrome-stable) from the Google website. Everything was good, it showed as an option in System->Details->Default Applications menu and I set it as default browser. A few days later, here I am looking at my Default Applications menu and Google Chrome is nowhere to be found. My default has reverted to Firefox. I tried uninstalling and reinstalling the google-chrome-stable package but to no avail. How can I get Google Chrome to reappear as an option in Default Applications list?

3
  • I should note I am using Ubuntu 15.10. Commented Feb 10, 2016 at 16:54
  • Have you tried : Uninstalling firefox than installing chrome and setting it as default later if you want install firefox again Commented Feb 10, 2016 at 17:37
  • Possible duplicate of How to set default program?
    – DnrDevil
    Commented Feb 10, 2016 at 22:59

2 Answers 2

3

I solved it! Somehow I had a corrupt google-chrome.desktop in my ~/.local/share/applications/ folder. I found the file in /usr/share/applications/ was valid. After deleting the bad one in my ~/.local/share/applications/ folder, logging out and back in, everything is back to normal. I can select Google Chrome from Default Applications and everything is golden.

1
  • This was exactly what fixed it for me.
    – madmaze
    Commented Aug 4, 2018 at 16:23
0

You should be able to set Chrome as default browser directly from Chrome settings. Have a look at the icon on top right of any Chrome tab (the three lines) and then Settings --> Default browser.

8
  • Chrome says it is currently the default browser. However, the Default Applications menu in Ubuntu shows Firefox as the default, and doesn't list Google Chrome. Commented Feb 10, 2016 at 17:04
  • When I click on a URL, FIrefox launches, so Google Chrome may think it is the default, but it isn't actually working. Commented Feb 10, 2016 at 17:06
  • And if you open a link on a .pdf or from any other application, it opens in Chrome or Firefox?
    – Sfrow
    Commented Feb 10, 2016 at 17:06
  • If you check on Firefox settings, it thinks to be the default browser as well?
    – Sfrow
    Commented Feb 10, 2016 at 17:07
  • 1
    So I cannot help you, I have Ubuntu 15.10 too, but I have in my list of default apps both Firefox and Chrome (I'm talking, of course, about System settings --> Details --> Default Apps) :( Sorry!
    – Sfrow
    Commented Feb 10, 2016 at 17:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .