4

I know this question has been asked a few times, but please bear with me. I'm new to Linux (only been using for a few months, but I like to think I have learnt fairly quickly, and am halfway confident using the terminal).
I recently purchased a Synology Diskstation 215j, and when I first set it up all things were working quite smoothly. A few days later, it would appear after an update on the diskstation, I can suddenly only access it through the web UI and FTP on my Ubuntu 15.10 laptop, and on my Raspberry Pi Openelec machine I can only access my media using Plex, whuich is not at all ideal. I would like to have the diskstation mounted at boot on both, if possible. Running

mount 192.168.1.ip:/volume/share /media/destination  

comes back, after quite some time, with an error message simply saying "mount.nfs: Connection timed out"
I have also tried mounting using SMB, which has consistently returned an error message either "error 22: invalid argument" or "error 115: operation in progress".
I have tried all sorts of variations on options, workarounds that people have used on this forum, specified "sec=" and changed settings on my NAS drive, installed helper programs, checked cables, all sorts. I've exhausted my own (meagre) knowledge and learnt plenty more while trying to sort this out, and now I'm totally stuck. Any help or suggestions would be fantastic.

Stuff I already looked at:

Plus a few more I can't remember right now.
Thanks from a newbie.

1
  • Stupid question but the mount command you show above, is that how is exactly typed?
    – Alex
    Mar 23, 2018 at 22:49

1 Answer 1

0

I've been looking for quite a bit to do exactly that (DS1621+, DSM7.0, Ubuntu 20.04.2 LTS), but would only get the dreaded 'Connection timed out' message.

After many unsuccessful attempts to troubleshoot, I finally bumped into this doc.

The instructions on this Synology help page are incorrect.

The actual mount command that made it work all of a sudden was:

sudo mount -t nfs4 -o proto=tcp,port=2049 nfs-server:/volume1/share /nfs/share

(Obviously do adapt the last two arguments as needed).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.