1

One of our computers running ubuntu 15.10 is very slow at restarting from hibernation. Slow as in today it took it 20 minutes to restart.

As in this conversation http://ubuntuforums.org/archive/index.php/t-1265428.html I have tried

sudo apt-get install uswsusp hibernate
sudo ln -sf /usr/sbin/hibernate /usr/sbin/pm-hibernate

And I have added "hibernate" as an option in acpi-support so that it looks like:

SUSPEND_METHODS="dbus-pm dbus-hal pm-utils hibernate"

But without any luck.

Looking through kernal.log I found this part:

Feb 10 10:10:17 EsterUbuntu kernel: [85315.222120] r8169 0000:03:00.0 eth0: link up
Feb 10 10:12:18 EsterUbuntu kernel: [85445.959914] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Feb 10 10:12:18 EsterUbuntu kernel: [85446.058819] r8169 0000:03:00.0 eth0: link down
Feb 10 10:12:18 EsterUbuntu kernel: [85446.058864] r8169 0000:03:00.0 eth0: link down
Feb 10 10:12:18 EsterUbuntu kernel: [85446.058885] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Feb 10 10:12:21 EsterUbuntu kernel: [85448.393706] r8169 0000:03:00.0 eth0: link up
Feb 10 10:12:21 EsterUbuntu kernel: [85448.393714] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Feb 10 10:28:50 EsterUbuntu kernel: [86436.508347] show_signal_msg: 39 callbacks suppressed
Feb 10 10:28:50 EsterUbuntu kernel: [86436.508351] chrome[3004]: segfault at 60 ip 000055be34436421 sp 00007ffd4f060660 error 4 in chrome[55be3138b000+58b8000]
Feb 10 10:35:36 EsterUbuntu kernel: [86842.047905] SGI XFS with ACLs, security attributes, realtime, no debug enabled

So first something with the network cards take two minutes and then it takes another 16 minutes before I get a message about callbacks suppressed and another 7 minutes before it carries on. After that no operation takes more than a couple of seconds.

I feel that I'm over my head in debugging this and would appreciate some tips regarding how to proceed. Is this a problem with the network card, the callbacks and segfault or an issue with Chrome?

EDIT: I fooled myself to think that ipv6 was the issue. Last time we timed it it took 8 minutes to start from hibernate.

1

I disabled ipv6 and the time for star up improved.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.