5

I have recently installed the NVIDIA drivers on my Xubuntu 15.10 machine but I had to remove them due to improper multi-monitor setup. Everything went fine, except for the fact that gpu-manager seems to overwrite my xorg.conf file with a wrong version containing NVIDIA stuff.

I know that there is a reported bug related to this, and I tried applying the hotfix suggested there but to no avail; namely, I changed /etc/init/gpu-manager.conf to:

#start on (starting lightdm
#      or starting gdm
#      or starting kdm
#      or starting xdm
#      or starting lxdm)
task
exec gpu-manager --log /var/log/gpu-manager.log

My xorg.config file keeps being overwritten with the NVIDIA stuff.

Any other suggestions? I am also a bit concerned that some people suggested that the hotfix above might freeze the syystem (whatever that means).

9

OK, as per this blogpost, adding nogpumanager to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub solves the issue. Thus, the line in /etc/default/grub should look like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nogpumanager"

After you edit the file, don't forget to run:

sudo update-grub
| improve this answer | |
  • 1
    Tried this, but xorg.conf still gets override – liang Apr 15 '18 at 11:44
2

Look here for all possible solution https://vxlabs.com/2015/02/05/solving-the-ubuntu-14-04-nvidia-346-nvidia-prime-black-screen-issue/#comments

one good solution is

 By doing sudo chattr +i /etc/X11/xorg.conf you can prevent any process from changing the file. 

But then I am not sure aticonfig --initial will work

| improve this answer | |
0

For those who get 640x480 screen or whatever problem and you had touchpad settings in the old overwritten xorg.conf file (those settings are already backed up in a file names similar to xorg.conf.12345678) The solution is: after commenting those lines out in /etc/init/gpu-manager.conf like this:

#start on (starting lightdm
#      or starting gdm
#      or starting kdm
#      or starting xdm
#      or starting lxdm)
task
exec gpu-manager --log /var/log/gpu-manager.log

All you have to do is to remove /etc/X11/xorg.conf file once then run sudo service lightdm restart and after that you see there is a new xorg.conf generated. You can copy old settings from xorg.conf.12345678 to the end of the new xorg.conf file. And restart lightdm service again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.