3

A little system description, I have 2 SSD drives running raid 0 strictly for boot drives. I also have a 1tb HDD that I am trying to add to /etc/fstab on ubuntu 15.10.

Here is my entry into /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/isw_cdaafghhha_Volume0p2 /               ext4    errors=remount-ro 0       1
/dev/mapper/isw_cdaafghhha_Volume0p1 /boot/efi       vfat    umask=0077      0       1
/dev/mapper/isw_cdaafghhha_Volume0p3 none            swap    sw              0       0
UUID=06c16279-3ef0-4c36-8879-d5e417324355 /media/brennan/06c16279-3ef0-4c36-8879-d5e417324355   ext3    defaults        0       0

Now when I run mount -a I get

mount: /etc/fstab: parse error: ignore entry at line 11.

Any ideas?

Thanks!!

  • It could be something as simple as a missing newline at the end of your new entry - worth checking anyhow – steeldriver Feb 10 '16 at 2:02
  • Tried adding a new line, still same issue :( – schmodee27 Feb 10 '16 at 2:04
  • I bet fstab just thinks the mount point is ugly :) Why not something simpler, if you are going to hard code it you can choose it! And just to be sure it's really ext3 not ext4? Thought maybe that's a typo? – JimLohse Feb 10 '16 at 4:22
1

Everything looks correct according to man fstab, make sure you copy/paste the UUID & the last 2 (5th & 6th) fields aren't required if zero.

I'd also go to the above line, delete the linebreak and press ENTER to insert it again, just to make sure it isn't actually breaking things there.

Use sudo nano or sudo vi to edit it, to avoid hidden character encodings.

  • I just read this in man mount - "When mounting a filesystem mentioned in fstab or mtab, it suffices to give only the device, or only the mount point.". So does mount /media/brennan/06c16279-3ef0-4c36-8879-d5e417324355 do anything? because that will read from fstab. You may want to change that folder name?! :) – Sir_Scofferoff Feb 10 '16 at 3:12
1

Use the blkid command to get UUID

root@ashu-700-430qe:/opt# blkid /dev/sdb3
/dev/sdb3: UUID="G6NJf4-YQGl-KikN-dMh7-2yUd-5Owf-4gCO2f" TYPE="LVM2_member" 

then use this UUID in place of /dev/sdb3 I am just using my system as an example. It will be different in your case. Make use of 'tab' to move from one column to another while editing /etc/fstab and after that make sure that you issue

sudo update-initramfs -u

so that changes are available at boot time.

You can also try mount -a to verify your changes immediately.

This is how my /etc/fstab looks like

root@ashu-700-430qe:/opt# cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation
UUID=54458154-6f44-44c9-be44-f91d093d63e6 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=E467-1A3B  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sda6 during installation
UUID=74a0518b-2eed-404a-aaa1-a302dbf9f18c none            swap    sw              0       0
#/dev/vgall/tmp     /tmp        ext4    defaults    0 2
#this is volume-opt
UUID=b3d302be-68f6-4804-abb1-ab806326b5a4   /opt    ext4    defaults    0   2
#/dev/mapper/vgall-var
#UUID=35d84c0b-d29b-4677-bc0f-26ef945d1ebf  /var    ext4    defaults    0   1
#/dev/mapper/vgall-usr
#UUID=e67910d0-09c9-4249-ba20-c4e471b30e63  /usr    ext4    defaults    0   2
#/dev/vgall/home
#/dev/mapper/vgall-home /home   ext4    defaults    0   2   
root@ashu-700-430qe:/opt# 

You can use the above one as reference in terms of understanding the format.

  • I did use the UUID, this is the line I added to /etc/fstab UUID=06c16279-3ef0-4c36-8879-d5e417324355 /media/brennan/06c16279-3ef0-4c36-8879-d5e417324355 ext3 defaults 0 0 Do I have any syntax errors? – schmodee27 Feb 10 '16 at 1:58
0

Recover Mode Read Only

I followed the next steps(Thank to @twister_void in this post ):

I did some web searching on "Recover Mode Read Only" and came across this post on LinuxQuestions.org website.

  1. Shutdown the computer
  2. Boot into Recovery Mode --After BIOS load, hold down Shift key to access the grub menu --Once in grub menu, select the entry ending in "(recovery mode)"
  3. From the next menu selected option to enter Root Session
  4. At the root session, execute command mount -o rw,remount / to remount the filesystem as read-write
  5. Ignore error on step 4 like ...parse error at line X ...

Remove the line on /etc/fstab

  1. Open the fstab file to remove the line X(in my case was line 1)

    # nano /etc/fstab

  2. Remove the line, you can use ctrl+k on nano editor

  3. Save the file without the bad line ctrl+x and ctrl+y
  4. Reboot

    # reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.