0

So I'm building my first home server and am having issues with the samba system all my computers can detect it but I am receiving errors telling me it is unaccessible. The computers in the house are both Windows and Linux. here is my samba setup

bal] ; General server settings netbios name = FieldsVille server string = workgroup = WORKGROUP announce version = 5.0 socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192

passdb backend = tdbsam
security = user
null passwords = true
username map = /etc/samba/smbusers
name resolve order = hosts wins bcast

wins support = yes

printing = CUPS
printcap name = CUPS

syslog = 1
syslog only = yes

; NOTE: If you need access to the user home directories uncomment the ; lines below and adjust the settings to your hearts content. [homes] valid users = %S create mode = 0600 directory mode = 0755 browseable = yes read only = no veto files = /.{}/.*/mail/bin/

; NOTE: Only needed if you run samba as a primary domain controller. ; Not needed as this config doesn't cover that matter. [netlogon] path = /var/lib/samba/netlogon admin users = Administrator valid users = %U read only = no

; NOTE: Again - only needed if you're running a primary domain controller. [Profiles] path = /var/lib/samba/profiles valid users = %U create mode = 0600 directory mode = 0700 writeable = yes browseable = yes

; NOTE: Inside this place you may build a printer driver repository for ; Windows - I'll cover this topic in another HOWTO. [print$] path = /var/lib/samba/printers browseable = yes guest ok = yes read only = yes write list = root create mask = 0664 directory mask = 0775

[printers] path = /tmp printable = yes guest ok = yes browseable = no

; Uncomment if you need to share your CD-/DVD-ROM Drive ;[DVD-ROM Drive] ;path = /media/cdrom ;browseable = yes ;read only = yes ;guest ok = yes

[MyFiles] path = /home/robert/main browseable = yes read only = no guest ok = yes create mask = 0644 directory mask = 0755 force user = YOUR_USERNAME force group = YOUR_USERGROUP

Any help would be great.

Also does anyone know any other possible programs to set up the file sharing for the server?

0

Are you use real server or just install samba package in your desktop system ? In my machine i added the samba configuration with this simple script :

[ISO_Linux]

path = /home/teluk/iso

guest ok = yes

read only = no

browseable = yes

Make sure your directory permissions is set to accessible for everyone but don't set writable permissions . This example command to make your shared directory is accessible without writable :

sudo chmod -R 755 /home/teluk/iso

After that restart the smbd dan nmd with this command :

sudo /etc/init.d/smbd restart && sudo /etc/init.d/nmbd restart

If you use Ubuntu desktop with samba , open your file manager like nautilus , pcmanfm , thunar etc. Press ctrl+L and type this to check it:

smb://localhost

if you done the shared directory is show up in your file manager , next you can try to access your samba in windows system with press windows_button+R then type //your_ip .

Good luck .

NB : "/home/teluk" is may home directory you can change that with your directory location .

0

Not sure if you're using the default smb.conf that's configured for ease of setting up or not. I'd recommend doing that first for debugging.

You need to run sudo smbpasswd -a <user> for each user that needs to login as well (I usually have to anyway).

There should be a default smb.conf at /usr/share/samba/smb.conf

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.