I recently attempted to remove the user indicator applet by disabling the "user-show-menu" option in /apps/indicator-session with the dconf-editor (as mentioned here). This worked great for a little, but I had trouble the next time I rebooted.

I was greeted with the lightdm login screen as usual, but when I entered my password, I was brought to a non-interactive console and could not do anything. This happened when trying to load any desktop environment (GNOME, GNOME Classic, Unity, Unity 2D, etc.). The problem appears to be that the display manager is not starting properly. Unfortunately, I do not know where to look for any sort of error message.

As a workaround, I was able to go into a virtual terminal with Ctrl-Alt-F1. If I ran the command sudo start gdm, I was brought to the the gdm login screen and everything was fine after the fact until I restarted. I found a temporary fix by reconfiguring gdm as my default window manager using sudo dpkg-reconfigure lightdm, which has allowed me to login to my computer as usual.

I like the appearance of the lightdm greeter way better, and would prefer to have that system working like it was before. I would really appreciate it if someone knew the solution to this, or could point me in the right direction of where to look for an error message.

Another note: Even though I have "user-show-menu" now enabled in dconf-editor, there is no user menu in my indicator bar. I'm running Ubuntu 11.10 64 bit on a ThinkPad Edge E420s.


| improve this question | | | | |
  • I doubt the removal of the user-show-menu and your login issues are connected. Its more likely a system update is causing you issues - have you got a proprietary graphics driver installed and did you install it yourself? - if the answer is yes to both, maybe a kernel update is causing your issue - try sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.back to get back to a working desktop and then reinstall your drivers. – fossfreedom Oct 28 '11 at 15:38
  • @fossfreedom I agree it seems strange, but these things happened immediately after one another, so I don't know what else it could be. Thankfully, the Intel graphics on the thinkpad are pretty well supported, and I don't have any proprietary drivers on my system. In fact, I don't even have an xorg.conf file, as I haven't had to make any changes that require it. – jat255 Oct 28 '11 at 16:21
  • The problem related to this question is very specific. Too Localized. – Luis Alvarado Apr 9 '12 at 19:24