0

From this post:

Often this is easier with the compose key. With that configured you use key combos to get the special characters. For instance:

For ë you press Compose+", e.
For ẽ you press Compose+~, e.
For ô you press Compose+^, o.
For á you press Compose+', a.
For à you press Compose+`, a.
For € you press Compose+=, e.
For £ you press Compose+-, l.

Note that you do not have to hold down the compose key; just press each key in order.

To set the compose key go to System -> Preferences -> Keyboard, then Layouts -> Options. Open up Compose Key Position and choose a key. I use Right-Alt."

I've been trying to do this for the past 24 hours and absolutely no special characters will bind to my compose key. Every time I type in a special code it lists it as "multikey" and I tried to set "á" to a million different key combinations and absolutely none of them work.

I NEED these special characters to do online spanish homework so I can't go without it. I can't to use the character map every single time I want to type a word.

See? See how I did everything you guys said on the forum and nothing works?

enter image description here

enter image description here

  • This will depend on what keyboard you currently have set. A spanish keyboard should have them on the keyboard itself ;-) An English-US will not and you probably will need English-US-international with dead keys-. But please provide us with what keyboard you have set at the moment ;) – Rinzwind Feb 9 '16 at 19:03
  • Its just on english. I want to set up a KEYBOARD SHORTCUT though and not change my keyboard language. That's my problem. Absolutely no shortcut I've tried to set yet has worked. None. – Emandudeguy Feb 9 '16 at 19:05
  • I don't know why you are setting shortcuts for these. The Compose key doesn't need shortcuts. It just needs to be enabled once. – muru Feb 9 '16 at 19:06
  • Well those codes I just rattled off at the top of the page do absolutely nothing on my end. "Compose+", e" etc none of them do anything but type the normal letter on the keyboard. – Emandudeguy Feb 9 '16 at 19:10
  • 1
    What have you set Compose to? Add a screenshot of that settings page. The keyboard shorcuts one is worthless. – muru Feb 9 '16 at 19:11
3

If you are using the "English (US)" keyboard layout now, you need to add a keyboard layout that supports those special keys.

Go to System Settings - Keyboard - Text Entry, and click the + button under the list of language input methods / keyboard layouts. You need something like "English (US, international)". If your keyboard is not a standard US keyboard, you can just choose the one that describes your keyboard. If you are using a standard US keyboard, then you need to know which key on your keyboard is a special key... It might be the right Alt.

Now I am using "English (US, international with dead keys)". It is a little bit different from what you describe. Now I can input ë by simply pressing " first, releasing, and then pressing e. Similarly I can also do é è ¿. I can input ' and " with Right Alt+', etc.

enter image description here

You should switch to the keyboard using the switcher icon in the system tray.

enter image description here

  • @EliasTurner That's weird. It works pretty well on all my Ubuntu machines. Have you added the same keyboard as is shown in the picture? When you switch to the keyboard, what happens when you press " or '? – bfrguci Feb 9 '16 at 19:27
  • @EliasTurner I don't hold any key down when typing those things... By the way, did you switch to the keyboard you added when you type? There is a layout switcher in the system tray. And btw, the keyboard you added is different from what I have so I am not sure whether that's a problem. – bfrguci Feb 9 '16 at 20:55
  • sorry about the mishap. I found the exact keyboard in bfrgucis picture and I ám ñów áblé to úsé my á©©ented letters without binding any shortcuts. still totally perplexed as to why I never got a single custom shortcut working. – Emandudeguy Feb 10 '16 at 1:12
  • @EliasTurner Hi! Glad that you finally made it! If you can accept my answer as the correct one I will appreciate it a lot - given that I am new here and really need some reputation :-) – bfrguci Feb 10 '16 at 19:09
0

Elias, it seems you have already configured what you need. As shown on the second image in this page, your compose key is set to "Left Ctrl", therefore in order to get ê type "letf-crtl" ^ e, I mean:

1- press and release left-crtl,

2- press and release ^,

3- press and release e.

If it is not working try to change the compose key to other key, like "Right Alt".

To do that click on "System Settings" "Keyboard" "Shortcuts" "typing" "Compose key"

In the line "Compose Key", click on the right side to open the menus and choose a new compose key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.