8

I suffer each time I return from a pause and I find my desktop stalled because the priority of tracker-extract consumes too much CPU (sometimes 104%), so I have to kill thru terminal the task (tracker-miner-fs, tracker-extract, and tracker-store) in order to return to my regular desktop activities.

I understand the importance of this program, but I do not want to solve its niceness issue every time by hand. And I do not want to remove it definetely.

Is there a configuration file so I can set it to my personal taste (I will choose a higher value so it really executes on a low priority level)?

Thanks

| improve this question | | | | |
5

Tracker's settings are now on dconf database, Managed through dconf-editor (GUI) or gsettings (CLI) under the org.freedesktop.Tracker.* tree:

screenshot

For Ubuntu 16.04, you could set indexing to run in the background with tracker-preferences. If that command wasn't already installed, you could install it with sudo apt install tracker-gui

After its initial complete index run, tracker — at least on a machine with SSD storage that isn't receiving huge dumps of new files — shouldn't take a significant time to run. If you find that tracker has locked up, I have suggested a solution here.

| improve this answer | | | | |
  • 3
    Although you are correct, it would have been helpful to the questioner if you had explained that to access the tracker-preferences, they should sudo apt-get install tracker-gui – Charles Green May 12 '17 at 22:30
  • @DavidFoerster I was way to busy playing with the new set of settings! – Charles Green May 13 '17 at 1:51
  • @scruss Thank you! Your answer is supercomplete. I also checked yourlink to the solution, which is exactly what I need to understand tracker issues. – LobaLuna Oct 18 '18 at 16:32
  • tracker-gui is only present on 16.04 – Pablo Bianchi Jul 24 '19 at 3:28
  • 1
    Did you know which key on dconf db is related to tracker-extract niceness/priority/CPU usage? – Pablo Bianchi Jul 24 '19 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.