0

Related questions have been asked quite often, but the solutions mentioned in those questions don't seem to solve my problem.

This quesion seems to be on the right track and I use it as a general guide. This question is also related.

So, when my WiFi is on and connected and I run nmcli nm I get:

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         connected       enabled         enabled    enabled         enabled   

If I then close the lid (sleep) and open it again (wake up) and run the command again, I get:

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         disconnected    disabled        disabled   enabled         enabled   

So the WIFI-HARDWARE and WIFI statusses changed from enabled to disabled.

Running man nmcli gives options I can use with nmcli nm and shows that I can switch WIFI on using nmcli nm wifi on, however if I run this it doesn't change the status of WIFI-HARDWARE or WIFI.

I think I can use a bash script and nmcli to fix this, but am not quite sure how. The original question says the following script:

#!/bin/sh

case "${1}" in
        resume|thaw)
        nmcli nm sleep false
                ;;
esac

should be placed in /etc/pm/sleep.d, this does however not fix my problem.

0

I was having the same problem on 16.10 where my Wifi would not reconnect after resuming. I tried restarting NetworkManager in a on-resume script, but it didn't work.

The solution that worked for me disabling and/or uninstalling ModemManager. Once that was gone, it started connecting again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.