1

I have a problem with my new desktop: low display resolution.

Here is some simple info of my desktop pc.
os: ubuntu 14.04 LTS
display card: nvidia gtx 960

I have searched a lot of solutions on Internet but none of them seems to work for me. And here are what I have tried.

Step1.

I have downloaded the latest nvidia driver for gtx 960 and install it via ubuntu software & updates.
I think the driver works because 2 two more display resolution were added(1360*768 & 1152*864) to my monitor while only 1024*768 & 800*600 were listed before. Besides, NVIDIA X Server Settings is available now. However, the problem is not solved.

Step2.

I tried to add a display resolution by using xrandr command. Following commands were executed:

joey@joey-B85M:~$ cvt 1680 1050 60
# 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz
Modeline "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync
    
joey@joey-B85M:~$ xrandr --newmode "1680x1050_60.00"  146.25  1680 1784 1960 2240 1050 
1053 1059 1089 -hsync +vsync
    
Then I executed xrandr command and the output is this:

Screen 0: minimum 8 x 8, current 1152 x 864, maximum 16384 x 16384
DVI-I-0 connected primary 1152x864+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0 +
   1360x768       60.0     59.8
1152x864 60.0* 800x600 72.2 60.3 56.2
680x384 60.0 59.8
640x480 59.9
512x384 60.0
400x300 72.2
320x240 60.1
DVI-I-1 disconnected (normal left inverted right x axis y axis) HDMI-0 disconnected (normal left inverted right x axis y axis) DP-0 disconnected (normal left inverted right x axis y axis) DP-1 disconnected (normal left inverted right x axis y axis) DVI-D-0 disconnected (normal left inverted right x axis y axis) 1680x1050_60.00 (0x1f9) 146.2MHz h: width 1680 start 1784 end 1960 total 2240 skew 0 clock 65.3KHz v: height 1050 start 1053 end 1059 total 1089 clock 60.0Hz

As you can see, I guess the point is that: I am adding a new display resolution to a display card which I am not actually using. I add 1680x1050_60.00 to DVI-D-0, the display card I should have in use. But actually, I am using DVI-I-0.

I searched again and think it may be a problem of xrog.conf, and tried to generate one. I run this:

Xorg -configure: 1
Here is the output:
X.Org X Server 1.17.1
Release Date: 2015-02-10
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-77-generic x86_64 Ubuntu
Current Operating System: Linux joey-B85M 3.19.0-49-generic #55~14.04.1-Ubuntu SMP Fri Jan 22 11:24:31 UTC 2016 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.19.0-49-generic root=UUID=94912055-e1da-4c3e-bd80-6d1b7209d320 ro drm.debug=0xe plymouth:debug
Build Date: 13 May 2015  04:35:05AM
xorg-server 2:1.17.1-0ubuntu3~trusty1 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.30.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Feb  9 16:15:51 2016
List of video drivers:
    siliconmotion
    intel
    r128
    sisusb
    vmware
    trident
    nvidia
    tdfx
    nouveau
    mga
    mach64
    radeon
    ati
    neomagic
    cirrus
    openchrome
    savage
    vesa
    fbdev
    modesetting
(++) Using config file: "/home/joey/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

Xorg detected your mouse at device /dev/input/mice. Please check your config if the mouse is still not operational, as by default Xorg tries to autodetect the protocol.

Your xorg.conf file is /home/joey/xorg.conf.new

To test the server, run 'X -config /home/joey/xorg.conf.new'

(EE) Server terminated with error (2). Closing log file.

Unfortunately, another error. Here is my xorg.conf.new file.

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files" ModulePath "/usr/lib/xorg/modules" FontPath "/usr/share/fonts/X11/misc" FontPath "/usr/share/fonts/X11/cyrillic" FontPath "/usr/share/fonts/X11/100dpi/:unscaled" FontPath "/usr/share/fonts/X11/75dpi/:unscaled" FontPath "/usr/share/fonts/X11/Type1" FontPath "/usr/share/fonts/X11/100dpi" FontPath "/usr/share/fonts/X11/75dpi" FontPath "built-ins" EndSection

Section "Module" Load "glx" EndSection

Section "InputDevice" Identifier "Keyboard0" Driver "kbd" EndSection

Section "InputDevice" Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/input/mice" Option "ZAxisMapping" "4 5 6 7" EndSection

Section "Monitor" Identifier "Monitor0" VendorName "Monitor Vendor" ModelName "Monitor Model" EndSection

Section "Device" Identifier "Card0" Driver "nvidia" BusID "PCI:1:0:0" EndSection

Section "Screen" Identifier "Screen0" Device "Card0" Monitor "Monitor0" SubSection "Display" Viewport 0 0 Depth 1 EndSubSection SubSection "Display" Viewport 0 0 Depth 4 EndSubSection SubSection "Display" Viewport 0 0 Depth 8 EndSubSection SubSection "Display" Viewport 0 0 Depth 15 EndSubSection SubSection "Display" Viewport 0 0 Depth 16 EndSubSection SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection

What should I do ? Will connecting to DVI-D-0 solve the problem? If so, how can I do this? By the way, how to post file in askubuntu.com ? So much post code is rather ugly.

EDIT: Output of command

lscpci -k | grep -EA2 'VGA|3D'
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1401 (rev a1)
Subsystem: Gigabyte Technology Co., Ltd Device 36be
Kernel driver in use: nvidia

  • Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command. – Pilot6 Feb 9 '16 at 13:34
  • @Pilot6 output of this cmd was added – joeyX Feb 11 '16 at 2:24
  • @joeyX Didn't you try to install/upgrade nvidia driver? – d a i s y Feb 11 '16 at 3:41
  • @MicrosoftLinux yes, I did. I installed latest nvidia driver for gtx 960 – joeyX Feb 11 '16 at 3:59
  • @joeyX I faced this problem many times and always solved with this method. See if it may help you. – d a i s y Feb 11 '16 at 4:08

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.