2

I have Ubuntu 14.04.03 working on my new Lenovo P50. There is one issue. Audio will not play out of the audio jack on the back of the docking station.

lspci -nn | grep Audio shows:

00:1f.3 Audio device [0403]: Intel Corporation Device [8086:a170] (rev 31)

I've tried modifying in /etc/modprobe.d/alsa-base.conf and adding these different options:

options snd-hda-intel model=thinkpad

and then I tried

options snd-hda-intel model=lenovo-dock

None of them worked. Anyone have any suggestions?

  • 1
    Could you please try again with 15.10 or at least the HWE wily kernel? If you haven't already wiki.ubuntu.com/DebuggingSoundProblems is worth a read. – LiveWireBT Feb 9 '16 at 14:00
  • Was this audio issue eventually resolved? Considering a P50. – Russ May 22 '16 at 12:07
  • Not yet. I reverted it back to Windows 10. – Byron May 24 '16 at 22:39
1

I had the exact same problem (same laptop, same Ubuntu version). I solved it following instructions from a website I dont remember anymore. According to my last shell commands, I did the following:

sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily 
sudo apt-get update 
sudo apt-get install oem-audio-hda-daily-lts-vivid-dkms

The following was added to my /etc/modprobe.d/alsa-base.conf (don't know if its needed):

options snd-hda-intel probe_mask=1 model=auto 
options snd-hda-intel model=pch position_fix=1
| improve this answer | |
  • This didn't work. I'm wondering if the port on the docking station is bad or not. I guess I can install Windows to find out. – Byron Feb 10 '16 at 14:56
  • Looks like the port is fine, this is definitely an issue with Ubuntu. – Byron Feb 10 '16 at 16:13
1

It's still valid - it's October, I have Ubuntu 14.04.5 (with the xenial kernel), and the exact same problem as Byron - tho my output lists like:

wjl@wjl-tp50:~$ lspci -nn | grep Audio
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-H HD Audio [8086:a170] (rev 31)
01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:0fbc] (rev a1)

Got the sound working without the docking station (also via HDMI), but not when the machine is docked.

And, unlike Byron, it also doesn't work with Windows 10. When I boot that up, the headphone jack on the back of the docking station is completely ignored, and the HDMI output(s) shown as 'inactive'.

Since I've tried that, I also don't have sound on the notebook's jack anymore, tho it is still recognized (hotpluggable) in Ubuntu.

Update: have to correct myself; it's working under W10 - so I'll open a bug in 'audio' for this...

Update: done; please see https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1630860

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.