1

I am writing because I have no idea what going on with my favourite os, Ubuntu 15.10 with the kde desktop. The problem affect ram usage in normal work (chromium/firefox browser with few cards and flash). I have set the vm.swappiness parameter to 1. I have 8GB of ram, and after few hours of work ubuntu use 90% of ram and 4GB of swap. It can be seen below after 2 hours of work:

root@celestia-laptop:/home/mariusz# free -m
             total       used       free     shared    buffers     cached
Mem:          7866       7707        159       4230         42       4732
-/+ buffers/cache:       2932       4934
Swap:        16391        920      15471

When I switch off the swap the system is going crazy - it's very slow, and hard drive usage is 100%. Maybe somebody have solution for my problem?

The output from the df -h command:

System plików  rozm. użyte dost. %uż. zamont. na
udev            3,9G  3,9G     0 100% /dev
tmpfs           787M  9,6M  778M   2% /run
/dev/sda10       36G   20G   15G  58% /
tmpfs           3,9G   78M  3,8G   2% /dev/shm
tmpfs           5,0M  4,0K  5,0M   1% /run/lock
tmpfs           3,9G     0  3,9G   0% /sys/fs/cgroup
/dev/sda8        80G   76G  4,9G  94% /media/BACKUP
/dev/sda9       282G  249G   20G  93% /media/DANE
/dev/sda2        96M   32M   65M  34% /boot/efi
tmpfs           787M     0  787M   0% /run/user/115
tmpfs           787M   46M  741M   6% /run/user/1000

the output of the htop command sorted by memory: image here

After kill all of browsers processes the output from the free -m command look like this.

root@celestia-laptop:/home/mariusz# free -m
             total       used       free     shared    buffers     cached
Mem:          7866       4486       3380       3087         38       3549
-/+ buffers/cache:        899       6967
Swap:        16391       1013      15378

You can see, that ubuntu use almost 2GB of memory.

I solved the problem temporary by change default tmpfs file system from 50% to 20%. Before run the kde desktop I remount tmpfs and devfs using following commands:

mount -o remount,size=20% /dev/
mount -o remount,size=20% /dev/shm
mount -o remount,size=20% /sys/fs/cgroup

I am wonder if there is permanent way to do this.

  • 1
    Possible duplicate of High RAM usage. – Weboide Feb 8 '16 at 20:33
  • Can you add the output of df to your question? – psusi Feb 8 '16 at 23:21
1

Run this command

sudo top

Find out the culprint process and then kill it

sudo kill -9 <pid>

enter image description here

Also look for some of the services that might be always running. For more details, refer to this link

  • The kill command do nothing, because this is not a solution. How can i use web browser if I kill it. But still if i kill browsers the free command looks like this: RAM: total=7866 used=4486 free=3380 shared=3087 buffers=38 cached=3549 -/+ buffers/cache: used= 899 free=6967 Swap: total=16391 used=1013 free=15378 . You can see, that ubuntu use almost 2GB of memory – Mariusz Ostrowski Feb 9 '16 at 6:58
  • In the startup processes there is no additional programs than in clean install. I solved the problem temporary by change the default tmpfs from 50% to 20%. I don't know how but this helps and the system use 1GB of ram. – Mariusz Ostrowski Feb 10 '16 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.