1

VSFTPD raise this error after checking the password of users that don't have a shell login to the server.

I have it and I can login without any problem. This is the log I see in Filezilla:

Stato:          Connessione a 95.110.226.115:21... 
Stato:        Connessione stabilita, in attesa del messaggio di benvenuto...
Risposta:   220 Welcome to LSSF FTP service. Comando:   AUTH TLS
Risposta:   234 Proceed with negotiation. 
Stato:         Inizializzazione TLS in corso... 
Stato:          Verifica del certificato in corso... 
Stato:          Connessione TLS stabilita.
Comando:    USER grafico 
Risposta:   331 Please specify the password.
Comando:    PASS ******* 
Errore:         Errore GnuTLS -15: An unexpected TLS packet was received. 
Errore:         Impossibile collegarsi al server

To enable the users without shell to login I added:

echo "/bin/false" >> /etc/shells

How to fix? Where should I look at? I need to have some accounts that can ftp but not login to the box!

0

I solved the issue re-creating the user with a home directory.

My vsftpd configuration is set to open the home directory for each user but the user I created was without both the ability to login via ssh and the home directory.

With the home directory and /bin/false as a shell it works fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.