I just got a new Lenovo ThinkStation P700 with Windows 7 Professional on it, and I would like very much to install Ubuntu on it.

I tried to install Ubuntu both 14.04 and 15.10, unsuccessfully.

First thing I did: update the BIOS to the last version. Still did not help.

With Ubuntu 15.10 I don't get any error, the monitor goes black and in power mode, and nothing happens. No 'acpi=off', 'nolapic', 'nomodeset' setting appears to help in anyway. Also, if I try those I get a kernel panic error...

My machine has an Intel Xeon E5-1620 v3 Processor (10MB Cache, 3.50GHz) and one grapihc card NVIDIA Quadro K620 2GB (DVI+DP).

Does anyone know how to fix this issue? Many thanks in advance :)

Now I will try with older versions...

Appears to be working with Ubuntu 13.04 and acpi=off nolapic nomodeset options. I'll keep you posted.


I successfully installed Ubuntu 13.04 using the acpi=off nolapic nomodeset options. Then, to upgrade to newer versions and update the software of the clean install of the old and no longer supported one, I followed the instruction from the answer here: How to install software or upgrade from an old unsupported release?

Once I got to Ubuntu 15.10 I removed the kernel options by doing sudo gedit /etc/default/grub & and then sudo update-grub.

Hope this might help :D

| improve this answer | |

I hit the same problem and successfully installed 15.10 by setting only one boot option, nomodeset

According to other threads, this option does the following.


The newest kernels have moved the video mode setting into the kernel. So all the programming of the hardware specific clock rates and registers on the video card happen in the kernel rather than in the X driver when the X server starts.. This makes it possible to have high resolution nice looking splash (boot) screens and flicker free transitions from boot splash to login screen. Unfortunately, on some cards this doesnt work properly and you end up with a black screen. Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded.

| improve this answer | |
  • Using just nomodeset did not work in my case... :/ – Qerubin Jul 20 '16 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.