2

After the latest updates to my Ubuntu 14.04 I can no longer connect to corporate WiFi using TLS and WPA2 Enterprise with certificate.

I did some research, and this bug (for Ubuntu 15.04) is the closest thing I have found. I seem to have the same problem but on Ubuntu 14.04.

I add some screenshot to demonstrate the problem.

Here is what I see when I try to create the connection:

problem during wifi connection creation

As you can see the "Save" button is disabled, and I simply cannot save my settings.

I thought I could work around this problem by manually creating a configuration file under /etc/NetworkManager/system-connections/. I did that, but still no luck. When I manually try to connect to the WiFi from the Network Manager applet I get the following dialog box:

connecting to wifi

As you can see, the "Connect" button is disabled, even after I enter the password.

Now I'm stuck. Any help is greatly appreciated.

For completeness:

  • kernel version: 3.13.0-77-generic
  • network-manager: 0.9.8.8-0ubuntu7.2
0

I figured out how to solve my issue, though I did it in a strange way. I'm posting this in case somebody else has the same problem.

The way I solved it is simply as follows:

  • create a new WiFi connection using a different authentication method (not TLS with certificates); put a fake password, and save it. This time the Network Manager will let you save the connection!

  • obviously the newly created connection will not work, but you can now go back in Network Manager, edit it, and change the Security to WPA2 Enterprise, and the Authentication to TLS, pick your certificates, and save.

Now everything will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.