1

From VLC and SMPlayer to Chrome, I am experiencing daily and even hourly video playback issues. For one, please look at this YouTube video that was playing in full-screen mode in Chrome and as soon as I exited full-screen mode, everything froze:

https://vimeo.com/154539410

Here's another video that shows that when I move the window of SMPlayer, the video area lags behind a little bit:

https://vimeo.com/154470574

My system specs are:

  • CPU: Core i7 6700
  • Graphics: Integrated Graphics
  • Ubuntu 15.10

I have also installed Intel® Graphics for Linux.

Are there any ways to fix these issues?


EDIT: When I run VLC in verbose mode, I get these messages in the log output:

VLC_VERBOSE=1 vlc
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[0000000001103148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00007fe7c0c01928] mp4 demux warning: STTS table of 1 entries
[00007fe7c0c01928] mp4 demux warning: STTS table of 1 entries
[00007fe7c2801178] faad decoder warning: decoded zero sample
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
[00000000011fe018] pulse audio output warning: starting late (-55388 us)
[00000000011fe018] core audio output warning: playback too early (-72418): down-sampling
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 168 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 160 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 152 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 144 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 136 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 192 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 184 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 176 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 168 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 160 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 152 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 144 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 136 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 192 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 184 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 176 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 168 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 160 ms)
[00007fe7b8252038] core video output warning: picture is too late to be displayed (missing 152 ms)

EDIT 2: I installed libvdpau_va_gl and deleted ~/.config/vlc to reset VLC's config and now I am getting these errors in the log output:

$ VLC_VERBOSE=1 vlc
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[000000000231b148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00007f06ecc018d8] mp4 demux warning: STTS table of 1 entries
[00007f06ecc018d8] mp4 demux warning: STTS table of 1 entries
[00007f06ee8012e8] faad decoder warning: decoded zero sample
libva info: VA-API version 0.38.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_38
libva info: va_openDriver() returns 0
[00007f06ee812258] avcodec decoder: Using OpenGL/VAAPI/libswscale backend for VDPAU for hardware decoding.
[h264 @ 0x7f06ee820640] hardware accelerator failed to decode picture
[h264 @ 0x7f06ee8acb80] hardware accelerator failed to decode picture
[0000000002415f68] pulse audio output warning: starting late (-55609 us)
[0000000002415f68] core audio output warning: playback too early (-71985): down-sampling
[h264 @ 0x7f06ee8f4460] hardware accelerator failed to decode picture
[h264 @ 0x7f06ee93bd60] hardware accelerator failed to decode picture
[00007f06bc001268] vdpau_display vout display error: video mixer surface width capabilities query failure: VDP_STATUS_NO_IMPLEMENTATION
[VS] error (vdpVideoSurfaceGetBitsYCbCr): not implemented conversion VA FOURCC  -> VDP_YCBCR_FORMAT_YV12
[00007f06bc5ff738] vdpau_chroma filter error: video surface export failure: VDP_STATUS_INVALID_Y_CB_CR_FORMAT
[00007f06e0251e78] core video output warning: picture is too late to be displayed (missing 168 ms)
[h264 @ 0x7f06ee820640] hardware accelerator failed to decode picture
[00007f06e0251e78] core video output warning: picture is too late to be displayed (missing 160 ms)
[h264 @ 0x7f06ee8acb80] hardware accelerator failed to decode picture
[00007f06e0251e78] core video output warning: picture is too late to be displayed (missing 152 ms)
[h264 @ 0x7f06ee8f4460] hardware accelerator failed to decode picture
[00007f06e0251e78] core video output warning: picture is too late to be displayed (missing 144 ms)
[h264 @ 0x7f06ee93bd60] hardware accelerator failed to decode picture
[h264 @ 0x7f06ee820640] hardware accelerator failed to decode picture
[h264 @ 0x7f06ee8acb80] hardware accelerator failed to decode picture
[h264 @ 0x7f06ee8f4460] hardware accelerator failed to decode picture
[h264 @ 0x7f06ee93bd60] hardware accelerator failed to decode picture
[h264 @ 0x7f06ee820640] hardware accelerator failed to decode picture
[h264 @ 0x7f06ee8acb80] hardware accelerator failed to decode picture
[h264 @ 0x7f06ee8f4460] hardware accelerator failed to decode picture
[00007f06ee812258] avcodec decoder warning: More than 4 late frames, dropping frame

After unchecking hardware acceleration I get a similar log in the output:

$ VLC_VERBOSE=1 vlc
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[0000000000868148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
QObject::~QObject: Timers cannot be stopped from another thread
behrangsa@Tesla:~$ VLC_VERBOSE=1 vlc
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[0000000000a6d148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00007fb3ccc01938] mp4 demux warning: STTS table of 1 entries
[00007fb3ccc01938] mp4 demux warning: STTS table of 1 entries
[00007fb3ce01d558] faad decoder warning: decoded zero sample
libva info: VA-API version 0.38.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_38
libva info: va_openDriver() returns 0
[00007fb3ce02e688] avcodec decoder: Using OpenGL/VAAPI/libswscale backend for VDPAU for hardware decoding.
[h264 @ 0x7fb3ce03ca60] hardware accelerator failed to decode picture
[h264 @ 0x7fb3ce0c8fa0] hardware accelerator failed to decode picture
[0000000000b67f68] pulse audio output warning: starting late (-55924 us)
[0000000000b67f68] core audio output warning: playback too early (-71494): down-sampling
[h264 @ 0x7fb3ce110880] hardware accelerator failed to decode picture
[h264 @ 0x7fb3ce158180] hardware accelerator failed to decode picture
[00007fb3b4001268] vdpau_display vout display error: video mixer surface width capabilities query failure: VDP_STATUS_NO_IMPLEMENTATION
[VS] error (vdpVideoSurfaceGetBitsYCbCr): not implemented conversion VA FOURCC  -> VDP_YCBCR_FORMAT_YV12
[00007fb3b4621478] vdpau_chroma filter error: video surface export failure: VDP_STATUS_INVALID_Y_CB_CR_FORMAT
[00007fb3c42417f8] core video output warning: picture is too late to be displayed (missing 168 ms)
[h264 @ 0x7fb3ce03ca60] hardware accelerator failed to decode picture
[00007fb3c42417f8] core video output warning: picture is too late to be displayed (missing 160 ms)
[h264 @ 0x7fb3ce0c8fa0] hardware accelerator failed to decode picture
[00007fb3c42417f8] core video output warning: picture is too late to be displayed (missing 152 ms)
[h264 @ 0x7fb3ce110880] hardware accelerator failed to decode picture
[00007fb3c42417f8] core video output warning: picture is too late to be displayed (missing 144 ms)
[h264 @ 0x7fb3ce158180] hardware accelerator failed to decode picture
[h264 @ 0x7fb3ce03ca60] hardware accelerator failed to decode picture
[h264 @ 0x7fb3ce0c8fa0] hardware accelerator failed to decode picture
[h264 @ 0x7fb3ce110880] hardware accelerator failed to decode picture
[h264 @ 0x7fb3ce158180] hardware accelerator failed to decode picture
[h264 @ 0x7fb3ce03ca60] hardware accelerator failed to decode picture
[h264 @ 0x7fb3ce0c8fa0] hardware accelerator failed to decode picture
[h264 @ 0x7fb3ce110880] hardware accelerator failed to decode picture
[00007fb3ce02e688] avcodec decoder warning: More than 4 late frames, dropping frame
[h264 @ 0x7fb3ce158180] hardware accelerator failed to decode picture
[00007fb3ce02e688] avcodec decoder warning: More than 4 late frames, dropping frame
[h264 @ 0x7fb3ce03ca60] hardware accelerator failed to decode picture
[00007fb3ce02e688] avcodec decoder warning: More than 4 late frames, dropping frame
[h264 @ 0x7fb3ce0c8fa0] hardware accelerator failed to decode picture
[00007fb3ce02e688] avcodec decoder warning: More than 4 late frames, dropping frame
[h264 @ 0x7fb3ce110880] hardware accelerator failed to decode picture
[00007fb3ce02e688] avcodec decoder warning: More than 4 late frames, dropping frame
[h264 @ 0x7fb3ce158180] hardware accelerator failed to decode picture
[00007fb3ce02e688] avcodec decoder warning: More than 4 late frames, dropping frame
[h264 @ 0x7fb3ce03ca60] hardware accelerator failed to decode picture
[00007fb3ce02e688] avcodec decoder warning: More than 4 late frames, dropping frame
[h264 @ 0x7fb3ce0c8fa0] hardware accelerator failed to decode picture
[00007fb3ce02e688] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007fb3ce02e688] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)

EDIT 3:

Running ffmpeg -i on the video produces the following output:

Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'Day 2-2016-01-27 20.31 Core Spring Training.mp4':
  Metadata:
    major_brand     : mp42
    minor_version   : 0
    compatible_brands: mp42isomavc1
    creation_time   : 2016-01-27 17:44:23
  Duration: 02:08:51.78, start: 0.000000, bitrate: 206 kb/s
    Stream #0:0(eng): Audio: aac (LC) (mp4a / 0x6134706D), 16000 Hz, mono, fltp, 64 kb/s (default)
    Metadata:
      handler_name    : AAC stream handler
    Stream #0:1(eng): Video: h264 (Baseline) (avc1 / 0x31637661), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 141 kb/s, 5 fps, 5 tbr, 90k tbn, 180k tbc (default)
    Metadata:
      handler_name    : Citrix h264 stream handler
      encoder         : AVC Coding
1
1

In SMPlayer: Options->Preferences->Video select Output driver other than xv. For example: gl. And try to play your video again. Hope it helps)

In VLC: Tools->Preferences->Video Uncheck Accelerated video output(Overlay)

1
  • The SMPlayer issue got fixed, the VLC one didn't. If anybody is interested in pursuing VLC guys to fix it ask them to re-open the ticket here. – βξhrαng Feb 12 '16 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.