Hi and thanks for ur attention. For z500 lenvo laptop there is a problem with brightness key on windows 8.1 and windows 10; and each one has their own solution. Currently I have windows 10 and for solving the brightness problem you should do a manipulation in intel graphic driver and it's:

"Open this file and search "FeatureTestControl" and change 0xF000 to 0xF048 (or change it to 0xFFFF if doesn't work) [PwrCons_IVB_AddSwSettings] ------> [PwrCons_IVB_AddSwSettings] HKR,, FeatureTestControl,%REG_DWORD%, 0xF000 ------> HKR,, FeatureTestControl,%REG_DWORD%, 0xF048"

after this my the brightness keys worked perfectly fine then I installed Ubuntu 15.10 and when I pressed the brightness key in this operating system for the first time, everything got dark. and now when I login to windows 10 the brightness key won't work either and the only time I can adjust the brightness is before login into any of this tow OSs ( I mean in the boot page panel). and when I go to Ubuntu everything gets dark again but when I login into windows 10 it's same as the adjustment I just made before the login, but still I have no control on the brightness.

for solving the problem on Ubuntu I have tried these solutions in this topic: Make xconf configuration permanent but for each solution I got an error

Can anyone save me from this disaster , it's really driving me crazy and I'm new to Ubuntu.


That's indeed a tough one, I agree... Here's a possible solution.

First we would have to boot ubuntu in recovery mode ('Advanced options for Ubuntu') and drop to a 'root' shell.

1.) As you see in the UI menu, the 'filesystem state' is 'read only',so first we would have do remount the '/' (root) filesystem read/write:

The command for this is... (as described here)

mount -o remount,rw /

That change will not be permanent, but only for the current session.

2.) Now we try to give the system some default brightness value after boot:

For that we ad a basic instruction to a file called '/etc/rc.local'. Open that file

nano /etc/rc.local

Use the arrow keys and ad the following line just above the 'exit 0' statement. The value '2000' should do but you can change that afterwards. Also this is for Intel GPUs only. For other brands the command would be different.

echo 2000 > /sys/class/backlight/intel_backlight/brightness

Save the file with < ctrl >X and the 'Y' key.

Maybe we have to enable the rc.local service

systemctl enable rc.local
systemctl start rc.local

3.) You can now exit the 'root' shell. Type...


... and then 'Resume normal boot' from the UI.

4.) If we are lucky you should now have some brightness in your Ubuntu system. You can now play with the '2000' value in a terminal with something like...

echo 2250 | sudo tee /sys/class/backlight/intel_backlight/brightness

If you found your desired value, change it in /etc/rc.local, to make it permanent (see above).

sudo nano /etc/rc.local

Indeed that doesn't yet solve your 'brightness key' problem, but you get a working system. I think that's a good start.

  • Thanks for your answer. In rc.local I only see this: echo 10 > /sys/class/backlight/acpi_video0/brightness is this ok? I replaced the line u said with this one. – Amir Feb 16 '16 at 19:53
  • And there is another problem. When I want to enable rc.local service I get this for multiple lines: ...no such file or directory. – Amir Feb 16 '16 at 19:55
  • Well... It looks like that value '10' could cause your problem. The whole line would indicate, that you have a proprietary card and driver running on that machine. Try to boot the system with a higher value than '10' – minimec Feb 20 '16 at 10:22

This one finally worked for me and I cant believe I'm seeing ubuntu with a full brightness :D


But the only thing u have to notice is that you should remove ur 20-intel.conf file in /usr/share/x11/xorg.conf untill this works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.