1

I am trying to dual boot Ubuntu 14.04.3 alongside Windows 10 using USB flash drive for booting. I get the following error, with all the combinations in UEFI Firmware settings I tried - initramfs: no medium found live file system windows 10.

I tried all the four combinations with Secure Boot and Legacy Boot. Also, I tried booting the same USB Drive in another Laptop (with BIOS), it booted successfully.

I created the USB drive using 'Startup Disk Creator' from another machine running on Ubuntu 14.04.

My machine is HP Pavilion x360 with Windows 10 pre-installed.Purchased 2 days ago.

I have read a lot of posts asking the similar question, but none of the answers there helped me. I suspect HPs UEFI Firmware for this issue. If anyone is able to give a solution for this would be really helpful.

Thanks in Advance.

1

Finally, I was able to install Ubuntu 14.04.3 in my new machine. Following is what I did, if it helps someone else.

My machine is HP-Pavilion x360 Convertible. It comes with Windows 10 pre-installed.

Initially I tried using Sandisk Ultra 3.0 32GB as the LiveUSB. It supports USB 3.0. I tried connecting it to sub 3.0 port as well as 2.0 port, landing with the same error(mentioned in the question). After, I tried using another Sandisk 32 GB that has dual head, one for smart phone, dont know the name of it. It comes with USB 3.0 as well. This one also gave the same error for 3.0 and 2.0 ports. And, I tried using the 15.10 image as well in both the USBs, landing in the same error.

After going through a lot of posts once more, I finally bought Sandisk 8GB Cruzer, which lot of posts says to be working properly. Luckly, it worked for me as well. I installed Ubuntu 14.04.3.

I installed using the first option of 'Install alongside Windows Boot Manager'. This was done with Secure Boot enabled. That means, I didnt change any UEFI firmware settings other than adding initial 5 seconds delay, so that I can enter the UEFI settings by pressing 'ESC' key at start.

After installation, I ran into the next problem, booting to Ubuntu. I could not modify the boot order, with any of the tools (efibootmgr, Boot-repair, EasyUEFI) or commands (bcdedit /set path {bootmgr} \EFI\ubuntu\shimx64.efi). What finally worked was, I started boot-repair, and inside Advanced Options> Main Options, I enabled 'Backup and rename Windows EFI files', and ran the repair boot. This solved the booting problem. Now, after power-on, it goes straight into the Grub menu, with a lot of entries, ubuntu as the first listed. But the default selected entry was 'Windows Boot Manager'. I then updated the Grub file to point to 'Ubuntu', from the Boot-repair.

I had the next problem, not connecting to wireless networks, rather, wireless connection not enabled. Again, after going though a lot of posts, I disabled bluetooth, and restarted. After restart, I saw the 'Enable Wireless' option, but could not tick it. I used the lspci -vnn command, which I found in a post (not able to find it now).

All these solved my problem of getting a proper Ubuntu 14.04 LTS up in my new Convertible.

Hope this might be of some help to someone else. I have my next problem, brightness buttons not working. I am going behind that.

Thanks.

|improve this answer|||||
0

First, if the computer shipped with Windows 10, do not enable the Compatibility Support Module (CSM; aka "legacy boot"); doing so just complicates the boot path and creates new problems. Disabling Secure Boot will not help, either; given the error message you got, your problem is clearly beyond the point where Secure Boot could be causing it.

Second, it could be that your disk was created incorrectly. Try another tool, such as Rufus or Unetbootin.. It sounds like the system can't find the initial RAM disk (initrd or initramfs), or that the code it contains can't find the rest of the installation image. I'm not sure of the precise meaning of that message, as it's a bit ambiguous; but it's something that could be caused by an improperly-created USB flash drive. You could also try another USB flash drive, since a failing USB flash drive could be the source of the problem, too.

Third, a more difficult possible cause is that your disk controller (note: disk controller on the motherboard, not the disk itself) is not yet supported by Ubuntu 14.04.3. You might try Ubuntu 15.10, which has a more recent kernel. (Ubuntu 14.04.4 will use the same kernel as 15.10, but it won't be out for a few days.) The pre-release Xenial images might also help, if you're willing to live on the "bleeding edge" for a couple of months.

|improve this answer|||||
  • Hi @Rod Smith, I tried creating the LiveUSB using Unetbootin, for 15.10. It still didn't work. Shows the same error. I think I will have to wait for a better release that addresses issues like these concerning UEFI. – vjn_amal Feb 8 '16 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.