I am using 14.04 on an AMD64 compatible system. Inside this system I am trying to run a virtual machine also with 14.04. I start qemu with this command:

qemu-system-x86_64 -cdrom ubuntu-14.04.3-desktop-amd64.iso -m 2048

Ubuntu boots inside qemu. But as soon as I move the mouse inside the qemu window, the cursor turns invisible. I can click on items just inside the border of the virtual screen, and this works so I know the mouse emulation is sort of working.

However since the cursor is invisible I have no idea where I am clicking when I try to click on something close to the center of the virtual screen.

What do I need to do to make the mouse cursor visible in qemu?

  • Is there a typo somewhere or are you actually trying to run Ubuntu 14.04 in a VM under 14.04? – Elder Geek Feb 7 '16 at 15:48
  • @ElderGeek No typo. Yes I am trying to run 14.04 in a VM under 14.04. – kasperd Feb 7 '16 at 15:50
  • I find that a bit puzzling, but I'm glad you got it sorted out. ;-) – Elder Geek Feb 7 '16 at 15:52
  • @ElderGeek I have my reasons. Next I am going to try to run qemu inside of that. Though with the slowdown I get from one layer of emulation, I don't think I'll ever manage to boot two layers of emulation. I suspect qemu might have been the wrong choice. – kasperd Feb 7 '16 at 15:59
  • @ElderGeek I just tried virtualbox instead. It turns out that virtualbox boots 12 times faster than qemu. – kasperd Feb 7 '16 at 16:21
up vote 1 down vote accepted

It turns out all I had to do was to add -show-cursor to the command line. Additionally I found that adding -enable-kvm reduced the bootup time from 10 minutes to 45 seconds. This version works:

qemu-system-x86_64 -show-cursor -enable-kvm -cdrom ubuntu-14.04.3-desktop-amd64.iso -m 2048

I find it a bit puzzling why this is not turned on by default.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.