0

I have an Odroid XU4 with Ubuntu 14.04 server installed and a Kingston DataTraveler pendrive, which works perfectly on other systems (Windows 7, Windows 8.1, Fedora 23, Mint, Ubuntu 14.04 desktop, Ubuntu 15, etc.). I mounted a pendrive, which I can read from. Now I try to copy files on it, but I got the no permission to write message. I checked with whoami that I am superuser (actually there is only root on the device currently, so it is not possible to be something else). I tried to mount it in read-write mode with the following command:

mount -o remount,rw /dev/sda /media/kingston-pendrive

I got that you must specify the filesystem type, which is odd, because it recognized NTFS in read mode automatically. By the following:

mount -o remount,rw -t ntfs /dev/sda /media/kingston-pendrive

I got a not mounted or bad option message. With force:

mount -o remount,rw -t ntfs -force /dev/sda /media/kingston-pendrive

I don't have any message, I am able to use the cp without error messages, but it does not copy the file.

I tried out without the remount option too, because I am not sure how it reacts on being unmounted:

mount -o rw /dev/sda /media/kingston-pendrive

I don't have any error message by mounting the drive, but I got the no permission message by trying to cp.

What is going on here?

update:

I got a HDD with a SATA-USB bridge. I managed to mount the HDD with mount -o rw /dev/sdb2 /media/asmedia-hdd. I can write on it. It has ext4 filesystem.

By the kingston pendrive I have NTFS filesystem. I checked with scandisk, and ntfsfix too. There is no problem with it. It still cannot mount in r/w mode. I don't know why, I suspect the NTFS in the background. I cannot use FAT32 on the long run, because it does not support large files, but I'll repartition it to FAT32 just to verify whether the problem is with the pendrive or with the NTFS filesystem.

1

It turned out that I need to install a special driver for NTFS filesystem. After apt-get install ntfs-3g the mount /dev/sda /media/kingston-pendrive worked properly and I was able to write to the pendrive.

More info here: https://linuxconfig.org/how-to-mount-partition-with-ntfs-file-system-and-read-write-access

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.