1

I am new to Kubuntu and I have an issue with the Digital Clock Widget.

First things first:

  • I did install NTP
  • datetimectl does say NTP Sync Yes and the Local Time is correct as well

    $ timedatectl
    Local time: sáb 2016-02-06 21:30:02 VET
    Universal time: dom 2016-02-07 02:00:02 UTC
    RTC time: dom 2016-02-07 02:00:02
    Time zone: America/Caracas (VET, -0430)
    Network time on: yes
    NTP synchronized: yes
    RTC in local TZ: no
    

However, ntpq shows just the following:

bbuske@bmstiL1:~$ sudo ntpq -np

remote refid st t when poll reach delay offset jitter

 186.71.75.78    .INIT.          16 u    -   64    0    0.000    0.000   0.000
 190.15.128.72   .INIT.          16 u    -   64    0    0.000    0.000   0.000
 146.164.48.5    .INIT.          16 u    -   64    0    0.000    0.000   0.000
 200.93.227.170  .INIT.          16 u    -   64    0    0.000    0.000   0.000
 91.189.89.199   .INIT.          16 u    -   64    0    0.000    0.000   0.000

This is however not the main problem. The main problem is with the digital clock widget on the task bar. The hour displayed there, is off one hour. Like right now it says 10:52 PM while it is 09:52 PM.

I went into the setting and revised the time zone (VET - Venezuelan Standard Time), which is correct, we also do not have DST and there is no option to enable it.

Now: The strange thing is, that in the settings itself, the time shows correct and is set to auto sync. It appears to be a sole issue with the desktop clock. I have tried the analog widget and the other one and both seem to show the correct time.

So I wonder if there is any way to have this fixed? Is there any way to modify the widget? Or anything else I can try? Of course I could just use the system settings to manually set the time one hour back, then the time would show correct but the system time would then be false. Another solution I found is, set the time to GMT and then in the settings for additional time zones, de-select Caracas / Venezuela and and select a time zone named GMT -4,30. Then I could just change the displayed time on the task bar to that one.

However: I would like to have my general time set to VET not to GMT. In the general time and date settings there is just one Caracas / Venezuela. The additional Options like GMT -4.5 are not present there but only in the widget settings.

I have seen this link here where someone from Venezuela had the same issues. However, he claimed that this has been fixed which apparently is not the case for me.

Any ideas or help would be much appreciated.

Cheers,

Ben

  • All the .INIT. lines in your ntpq -p (you do not need sudo for ntpq) show that clock synchronization is still initializing, What does date;TZ=PST date;TZ=EST date show? Is VET the same as PST? – waltinator Feb 7 '16 at 3:06
  • I know, but it has been on .INIT. for hours... and still is... The commands you mentioning both bring up the same time, our VET: bbuske@bmstiL1:~$ date;TZ=PST sáb feb 6 22:44:09 VET 2016 bbuske@bmstiL1:~$ date;TZ=EST sáb feb 6 22:44:25 VET 2016 VET is GMT -4.5 so I think it is EST with 1,5 hours missing... PST is like 2,5h ahead of us. – BenjB Feb 7 '16 at 3:15
  • It looks to me as if you have two problems: non-working NTP, and possible errors in the timezone definition. If you do sudo service ntp restart, does it help (with the .INIT. problem)? For the timezone errors, read man zdump;man -a tzselect;man tzfile. Since zdump PST VET shows the same time, Either VET is not what you think it is, or the VET timezone definition is incorrect, or something else – waltinator Feb 7 '16 at 14:57
  • @waltinator Thanls for the reply. The sudo service ntp restartdid not help. And yes you are right, apparently the PST and VET time show the same time. That said, it leaves me with two facts / questions: 1. Why is the time I see in the system settings correct (System Setting -> Time and Date) but shows wrong on the taskbar (only for the digital clock, the other clock widgets do show the time correctly!) and 2. I have checked the Caracas time file and it says the correct value GMT -4.5 so I have no idea why the zdump shows PST and VET the same. Also I have no clue whats wrong with the NTP. – BenjB Feb 7 '16 at 15:20
  • I have run tzselecton Venezuela with these results: The following information has been given: Venezuela Therefore TZ='America/Caracas' will be used. Local time is now: dom feb 7 10:54:29 VET 2016. Universal Time is now: dom feb 7 15:24:29 UTC 2016. All this info is correct and matches what is seen on the System Settings page. However, the Taskbar Widget keeps showing the wrong time (1h ahead). I am thinking it might be an issue with that particular Widget... since the others work and system time is correct. Still the question remains why the NTP Server keeps saying .init. – BenjB Feb 7 '16 at 15:27
0

So I was able to find a solution on my own.

First of all, as I have guessed, the issue was not with the system itself, but with the Digital Clock Plasma Widget. I could confirm that, since the system time in the system settings was correct and because the other clock widgets for the analog clock and the written clock were working correctly.

Attempts to find that widgets config or reference file to fix it manually or do some further investigation on the issue remained fruitless.

Today I had an automatic update check done after activating the kde-backtrack apt in Software Center. Promptly the system showed up various updates to KDE. After installing them all, without a reboot the clock was fixed and the visual effects, especially those of the taskbar significantly imporved.

Thanks everyone for attempting to help out.

Cheers.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.