3

My ethernet has stopped working, leaving me with wireless only:

enter image description here

This seems to be a common problem but I have yet to find a fix.

Standard diagnostics

$ ifconfig -a

eth0      Link encap:Ethernet  HWaddr 68:f7:28:39:71:5d  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0:avahi Link encap:Ethernet  HWaddr 68:f7:28:39:71:5d  
          inet addr:169.254.6.136  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2208 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2208 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:190071 (190.0 KB)  TX bytes:190071 (190.0 KB)

wlan0     Link encap:Ethernet  HWaddr 74:29:af:29:9b:09  
          inet addr:192.168.1.94  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::7629:afff:fe29:9b09/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:689 errors:0 dropped:0 overruns:0 frame:0
          TX packets:570 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:268689 (268.6 KB)  TX bytes:135063 (135.0 KB)

$ sudo lshw -C network

  *-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 10
       serial: 68:f7:28:39:71:5d
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:61 ioport:5000(size=256) memory:c3504000-c3504fff memory:c3500000-c3503fff
  *-network
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: 74:29:af:29:9b:09
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=3.16.0-59-generic firmware=N/A ip=192.168.1.94 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:19 ioport:4000(size=256) memory:c3400000-c3403fff

$ lspci | grep Ethernet

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)

$ cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

$ cat /etc/NetworkManager/NetworkManager.conf

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

$ cat /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
search home

$ netstat -rn

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.1.254   0.0.0.0         UG        0 0          0 wlan0
0.0.0.0         0.0.0.0         0.0.0.0         U         0 0          0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 wlan0

Attempted solutions

I have ruled out the obvious (reboot, change the wire, router port), and I have tried all of the following but to no avail (and so have reversed them):

I tried adding the lines:

auto eth0
iface eth0 inet dhcp

to /etc/network/interfaces, and restarting the service:

$ sudo service network-manager restart

I tried changing 'false' to 'true' in /etc/NetworkManager/NetworkManager.conf and restarting

I ran this (whatever it does):

$ sudo ethtool -s eth0 speed 100 duplex full

EDIT

In response to Jeff Sereno's suggestions:

$ sudo ifconfig eth0 up

$ sudo dhclient

RTNETLINK answers: File exists

No change (even with a restart).

$ cat /etc/udev/rules.d/70-persistent-net.rules

# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="68:f7:28:39:71:5d", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10ec:0xb723 (rtl8723be)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="74:29:af:29:9b:09", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

There is only the one ethernet entry.

I don't know if these offer new clues, but I also ran:

$ dmesg | grep eth0

[    0.749460] r8169 0000:01:00.0 eth0: RTL8168g/8111g at 0xffffc9000001e000, 68:f7:28:39:71:5d, XID 10900880 IRQ 61
[    0.749463] r8169 0000:01:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[   20.811216] r8169 0000:01:00.0 eth0: link down
[   20.811261] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[  539.016509] r8169 0000:01:00.0 eth0: link down
[  539.016602] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

$ sudo nm-tool

...

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        68:F7:28:39:71:5D

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

It says the eth0 state is 'unavailable' and wired properties 'off'...?

2

While Googling, I came across a few instances of others suffering with the same problem as me only to discover their ethernet cables weren't working, or something equally trivial. Hah! What idiots! Surely that's the first thing you check! ... Well, it turns out the power cable had ever-so-slightly slipped out of my network switch.

I shall hang my head in shame.

  • 1
    It's always something simple in the end... lol. – Jeff Sereno Feb 10 '16 at 0:30
  • 1
    omg!!!! I was having the exact same trouble. I went down the same path and had tried many of the same fixes you mentioned...I was so frustrated... I was panicking...... I then pushed a little harder on the ethernet cord..... OMG!!!!! I TOO hang my head in shame. – rikkitikkitumbo Jan 12 '18 at 20:34
  • @rikkitikkitumbo I knew it would help someone some day :) – lemon Jan 13 '18 at 11:12
0

Put your /etc/NetworkManager/NetworkManager.conf file back the way it was - you'll just break Network Manager for no reason. Also remove the eth0 entry from /etc/network/interfaces because Network Manager is managing it.

Your Ethernet card is definitely not disabled, so try:

sudo ifconfig eth0 up
sudo dhclient

And see if you get an address assigned that way.

Also check your /etc/udev/rules.d/70-persistent-net.rules file to make sure you don't have multiple "eth0" adapters defined (common occurrence when replacing old hardware with new hardware, but not reinstalling the OS). If you do, I recommend deleting all the adapters shown, reboot and let Ubuntu re-detect and re-populate this file for you.

  • Thanks. Unfortunately no change. I have edited by question with more detail... – lemon Feb 7 '16 at 9:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.