I was trying to install the crossover package on my laptop when the following happened:

  1. Icons started getting removed from the sidebar (or launcher?)
  2. The package manager was unresponsive for >5 minutes when I tried to stop the installation
  3. I tried to shutdown and at this point everything else was also unresponsive
  4. I shut it down with a long press of the power button
  5. I start it again and it's stuck in the start up screen (purple background + 5 dots)

apt-get upgrade results in this:

enter image description here (Click images to enlarge)


enter image description here

There were some other questions which were solved by fixing LightDM; however that's correct in my laptop.

This is the output on pressing Esc:

kernel output

There was a thread which suggested aptitude install lightdm but when I do that I'm told that all the packages mentioned above (in apt-get upgrade) will be removed and ~500 MB will be freed. So I'm not sure if that's the way to go.

  • more details needed like dmesg and syslog along with your h/w configuration
    – Ashu
    Feb 6, 2016 at 18:42
  • My laptop is an inspiron 3521; afaik it has an Intel graphics card and not nvidia! $ nvidia detector -> none
    – rohithpr
    Feb 6, 2016 at 18:57
  • You probably broke a few packages when you shut down your computer in the middle of an upgrade. Please edit your question to include (a link to) the content of /var/log/apt/history.log and /var/log/apt/term.log. Also, please use text instead of images to reproduce text content (see How can I run a command and copy its output? and How can I easily share the output of a command or a text file with others?). It is much more accessible and searchable. Feb 7, 2016 at 19:06
  • @DavidFoerster - Thanks for the edit! I wrote the question from my phone when I was locked out of my laptop; hence the crappy formatting! I had to resort to uploading images because I wasn't able to login but was stuck with the terminal that we get on doing ctrl + alt + F1. There's no copy-paste there!
    – rohithpr
    Feb 8, 2016 at 3:15
  • The questions linked in my previous comment contain many approaches to purely command-line based solutions which work in any virtual terminal. You only need a working internet connection (or a writeable external storage medium and a seconds computer – but this way is more complicated). Feb 8, 2016 at 8:58

2 Answers 2


A random thought made me try unity -v which told me that unity wasn't installed.

$ sudo apt-get install unity and I got to the login screen. Here I couldn't get in despite entering the correct password.

By following the steps given here I entered sudo apt-get install ubuntu-desktop and managed to login.

A few programs that were previously installed are now missing but I managed to login successfully without losing any files.


Have you try this:

sudo apt-get install --reinstall unity
dconf reset -f /etc/compiz 
unity --replace --reset-icon &disown

and it might work fine this way

  • I've already solved the issue using sudo apt-get install unity so there's no way for me to test your solution but it looks similar, so please leave it here! Thanks!
    – rohithpr
    Feb 7, 2016 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.