1

I recently purchased a lenovo ideapad300 and installed a dual boot system. the wifi for windows 10 works seamlessly while its problematic in ubuntu

this is the output for lspci -knn | grep Net -A2

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter [10ec:8821]
    Subsystem: Lenovo Device [17aa:a814]
    Kernel driver in use: rtl8821ae

i've tried reinstlling the driver using the instructions from this link. But still having problems.

http://ubuntuforums.org/showthread.php?t=2245164&page=2

this is my kernel version if that should help

Linux frostmourne 4.2.0-27-generic #32-Ubuntu SMP Fri Jan 22 04:49:08 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
2

In many cases, the issue with "...i'm getting a good connection when im close to the router.. but once i step a few meters away .. the signal drastically drops..." is a sign that the Linux driver is unable to sense and change to the antenna connector that is active, that is, has the wire connected. This is a well-known issue with the rtl8723be. There are a few options.

In the case of the rtl8723be, a revised driver has been written that allows antenna selection. In other words, if you have low or poor signal strength, the driver allows a parameter: ant_sel=2. In most cases, selecting antenna connection #2 provides excellent strength.

I have examined the latest driver for rtl8821ae and I find these manipulable parameters:

parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 1)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
parm:           int_clear:Set to 0 to disable interrupt clear before set (default 1)
 (bool)

There is no ant_sel parameter.

Another option is to open the computer, following, of course, all the precautions listed in the service manual that I am confident that you can find on line. Find the wireless card and change the antenna connector to the opposite post: http://i.ebayimg.com/00/s/Nzk2WDg3Nw==/z/XmYAAOSweW5VRppE/$_1.JPG?set_id=880000500F In this example, which may or may not be exactly like your wireless card, if your wire is on post A, change it to post M.

Replace the cover, battery, etc. and restart the computer. Is the wireless signal strength good? If so, you have confirmed that this is an ant_sel issue.

If that is the case, I suggest you file an issue against the driver here: https://github.com/lwfinger/rtlwifi_new/issues

  • would this affect the performance in windows as well? (changing the antenna position) – Kannaj Feb 9 '16 at 5:04
  • @Kunkka I don't know for sure as I haven't the device nor Windows; however, I believe the Windows driver auto-selects the antenna connection that is active. – chili555 Feb 12 '16 at 15:32
  • have any ideas on this one? askubuntu.com/questions/755256/… We're discussing it in chat now. I'm not really familiar enough with this stuff to tell if the problem is the same or not.. – Seth Apr 12 '16 at 0:47
1

I had the same problem with rtl8821ae on my asus laptop on Ubuntu 15.10. I tried a variety of things. This is what finally "worked" for me: - created a file /etc/modprobe.d/rtl8821ae.conf - after much trial and error added msi=0 to that file

$ pwd
/etc/modprobe.d
$ ls rtl8821.conf
rtl8821.conf
$ cat rtl8821.conf
options rtl8821ae  debug=0 disable_watchdog=N fwlps=N swlps=Y swenc=Y ips=N msi=0
  • I have not tried all of the other combinations of disable_watchdog/fwlps/swlps/swenc/ips so I don't know if there is a better set of parameters to set

  • This works ok on 2.4G. It does not work in 5G, the drop-outs are too severe for it to be useful.

  • on 2.4G, speedtest.net says I'm getting 24Mbs, other laptops and my phone are getting 100+Mbs, so there is still something wrong with the settings... but it's usable at least
  • the msi=0 was from this site https://github.com/lwfinger/rtlwifi_new/issues/64
  • added this .. no change as such :( .. sigh – Kannaj Feb 13 '16 at 11:25
1

After searching a lot, the following options worked for me on ubuntu 16. Its worth a try-

In rtl8821ae.conf:

options rtl8821ae disable_watchdog=0 swlps=1 swenc=1 ips=0 fwlps=0 msi=1 debug=0 int_clear=0

0

You can install a new driver. I just updated the PPA to the latest version.

Run in terminal:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms

Reboot after install.

Remove this driver by:

sudo apt-get purge rtlwifi-new-dkms
sudo add-apt-repository -r ppa:hanipouspilot/rtlwifi
  • now my ubuntu doesnt seem to detect the network :(. Where is it going wrong? – Kannaj Feb 6 '16 at 14:36
  • You can always remove this driver. I did not test it on 8821ae. There are drivers for many Realtek adapters. – Pilot6 Feb 6 '16 at 14:37
  • could you tell me how to revert back to the previous state? – Kannaj Feb 6 '16 at 14:38
  • Or maybe the problem is with the previous attempts. – Pilot6 Feb 6 '16 at 14:38
  • 1
    For further information, see post #17 here: ubuntuforums.org/… – chili555 Feb 6 '16 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.